asked on May 25

We just deployed our Weblink 11 server and we have users who've been using it since, but periodically report, "Tonight's Laserfiche error is 'Cookies are not enabled for this website. Cookies must be enabled in order to sign in to Weblink 10". Have a good evening!'"

I know the problem is the "&cr=1" that gets appended to the url automatically. When the user makes their shortcut or saves it as a favorite it includes that, and will probably include the "&cr=1". We have a public weblink and every link to it on our website does NOT include that, but because of it being automatically added to the link, all of the external entities that use it probably save it with that, so just telling the users to remove that is difficult.

Is there a way to alleviate this? Can I do some sort of redirect in IIS? I found this question which seems relevant but at the bottom it says it's been incorporated into Weblink 10.  https://answers.laserfiche.com/questions/69116/Preventing-False-License-Usage-in-WebLink 

It also looks like people have been complaining about this for at least two previous versions.

Weblink 9: https://answers.laserfiche.com/questions/77039/Weblink-displaying-Cookies-are-not-enabled-for-this-website-Cookies-must-be-enabled-in-order-to-sign-in-to-Weblink-9-error-message#158552

Weblink 9 and 10: https://answers.laserfiche.com/questions/164945/Cookies-are-not-enabled-for-this-website-Cookies-must-be-enabled-in-order-to-sign-in-to-Weblink-9#188315

I don't know how to mitigate this. It's frustrating.

Steve

4 0