You are viewing limited content. For full access, please sign in.

Question

Question

Weblink displaying "Cookies are not enabled for this website. Cookies must be enabled in order to sign in to Weblink 9" error message.

asked on May 12, 2015

My customer has this error that has started recently. He's recently upgraded to Weblink 9 and it worked fine for a few days then we are seeing this error. If we click Back to Welcome Page the Weblink session works properly at that point. It seems that all clients are getting this behavior.

1 0

Answer

SELECTED ANSWER
replied on May 12, 2015 Show version history

Hi Jeremy,

Are the clients using any particular URL to get to WebLink?  It's possible to get the cookies error despite cookies being enabled, if the URL contains the parameter cr=1.  That parameter tells WebLink to check for a cookie it has already sent the browser -- but if the original URL contains that string, WL doesn't get a chance to send the cookie before checking for it.  

5 0
replied on May 13, 2015

thank you so much for this. That was exactly the issue.

0 0
replied on September 22, 2015

We just recently upgraded to 9 and I am having the same issue. I do get the cr=1 on my URL. How do I fix it?

1 0
replied on October 2, 2015

Hello Melanie,

 

Can you tell me how I fix this issue? I am getting a bunch of complaints regarding the cookies issue.

0 0
replied on October 2, 2015

Hi Michael, 

Are users accessing WL through a URL with cr=1 at the end?  It shouldn't be a problem if you see that in the URL after you visit the page; the issue arises if the user is going directly to a page with, e.g., yourwebsite.com/WebLink/?cr=1 or yourwebsite.com/WebLink/Welcome.aspx?cr=1.

So if you're using WebLink externally, the solution is to set up your public link to WebLink so that it doesn't contain that parameter (so, yourwebsite.com/WebLink instead).  If you're using it internally, the solution is to tell your users not to include that parameter when accessing WebLink.  

2 1

Replies

replied on April 30

I noticed when I opened internet explorer and I pasted the link to the welcome page for WL (we have weblink 10.1) once I press enter, the "Welcome/aspx?cr=1" appears automatically. So Im attempting to access it through a link that doesnt have the cr=1 at the end, but it just gets added automatically. Is there any way to make that NOT appear??

1 0
replied on November 28, 2016

It would be great to somehow have a setting to force it not to add that to the URL.  Our Communications Staff normally post the links from our public WebLink reports in our newsletters and will have to remember and understand how to get rid of that out of the links.

 


 
 

0 0
replied on April 3

I am having issues for past couple of months using Weblink 10.1. when we connect to http://records.cupertino.org/weblink/Browse.aspx?startid=676&dbid=0  it automatically adds &cr=1 at the end of it and the message says 'No records found' in Chrome and IE but when you refresh it, it starts displaying the records. Any help is appreciated.

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.