You are viewing limited content. For full access, please sign in.

Question

Question

CPU maxing to 100% at Quick fields session

asked on October 17, 2014

We have a quick fields session which is doing OCR'ing for all the pages scanned. (screenshot attached)

This session is scheduled to run every 1 minute (by QF Agent).

When this session runs, it nearly kills the system, where it utilizes 100% CPU (Graph.png attached).

The specs for the system are: 

- Dual 2.70  GHz Intel Xeon(R)E5-2680 0

- 6 Gb RAM

- Win Server 2012 (no SPs)

 

Any idea how can we make this better?

Graph.png
QF Session screenshot.png
Graph.png (34.96 KB)
2 0

Answer

SELECTED ANSWER
replied on October 17, 2014

Each and every OCR Process will consume all the CPU cycles it can on *one* processor. 

 

Most of the time with QF Agent I recommend at least 3 cores, since up to two OCR processes can be run at once. Quick Fields can execute more than 2 QF sessions at a time but if there are OCR or Zone OCR in the QF sessions those threads can only run up to 2 times simultaneously on a particular machine (this is a license restriction between Laserfiche and the makers of Omnipro). I've run into issues with this where sessions time out mid stream if I have lots of OCR and try to bump it over 2 so most of the time I limit my customers to 2 QF agent sessions at a time. 

 

So if you follow that logic, 3 cores is usually sufficient because the 3rd core is your OS and other overhead. Since your screenshot shows 2 cores that's probably what's happening. Outside of the OCR process QF doesn't tax the processor too much as long as you have it installed on a local hard drive (not on a network hd, it can thrash a network connection with all of the file writes it does temporarily).

 

Incidentally the 2 OCR sessions at once apply for ANY LF product. So if Import Agent is running on that same machine that can steal slots of OCR from Quick Fields since all of them use Omnipro. But that's what multiple VM's are for, right? wink 

2 0
replied on October 17, 2014

Thanks for the detailed reply Chris.

1 0
replied on November 11, 2014

Hi Chris,

So I am back :)

 

After upgrading the cores to 4 cores, CPU is still maxing out with the same 3 schedules running. Screenshots attached.

 

Please note: All three sessions are set-up to run after 1 minute (1 minute is a requirement).

 

Any ideas?

 

Thanks

CPU Maxing.jpg
LF Using All CPUs.jpg
Schedules.png
CPU Maxing.jpg (34.32 KB)
Schedules.png (30.39 KB)
1 0
replied on November 11, 2014

wow. how is the throughput? Did it speed up any?

 

Laserfiche might be able to look into this deeper to see where the slowdowns are. One thing to check for is to see where your disk i/o is at. Quickfields is very very disk intensive and if the back end of this VM is writing across an unoptimized network to disk it can be pretty slow. If the CPU Is waiting for the disk to return data it needs to process something it can peg the CPU. You may have seen this happen in the past with machines that are simply file servers if there are too many requests at once. THe CPU's get pegged waiting for the different threads that are writing/transmitting to complete. 

 

If you have the ability I like to make a local HD on that machine the location for the install of the QF session and also where the  "save temporary documents" are placed. (this is in under tools/options/advanced).

 

Keep in mind that's just a shot in the dark - but I rarely see a pegging of all the CPU's like I see in your screenshot. So if I was troubleshooting that's what I'd look at next.  

1 0
replied on November 11, 2014

What are the settings in Capture Engine? How many documents are you expecting each session to pull from Laserfiche?

1 0
replied on November 12, 2014

Hi Miruna,

 

There would be more documents per run perhaps 8-10 per batch.

Capture Engine settings are very similar to the default settings, where we have repository connection configured, retrieve entries from path configured, type of documents to import are Documents, Documents short-cuts and Electronic documents. Document contents as: Keep each entry as seperate document, retrieve electronic files (as most of the documents in repo are PDFs) and retrieve fields.

 

We have another server with another instance of QF installed and it's maxing out to 100% as well. This has only 1 schedule configured and has 2 cores (with no users logged in and doing doing anything else).

 

Do you think that should I raise a support ticket for this issue and it's now become a show-stopper?

1 0
replied on November 12, 2014

It's not entirely clear to me from the screenshots and description if this is actually indicating a problem. Quick Fields is expected to use as many resources as needed. Is the CPU usage going back down when the session is finished?

Your screenshot is showing 3 Capture Engine processes running and you have 3 session scheduled at the same time. If the CPU is being released when the run is finished, then it's expected behavior.

1 0
replied on November 14, 2014

Hi Miruna,

 

I have a compiled all the findings in a small word document.

Please see attached.

Does this give you enough details on the contents of sessions and other diagnosis we have done.

Thanks

 

1 0
replied on July 3, 2015

That information was great.

Does the same limit apply to the OCR'ing using Distributed Computing as well? Means, If the OCR engine used by DCC is also based on the OmniPage product, is it also limited to “two OCR instances per OS installation"?

 

Thanks

0 0

Replies

replied on October 17, 2014

E5-2680 is a 8-core chip, so I assume you're running this in a VM since only 2 are available. Make more cores available to the guest, and you'll probably see much better performance.

1 0
replied on October 17, 2014

I will do. Thanks Corey.

1 0
replied on December 9, 2019

Hi Miruna,

We have similar problem whereas CPU usage is constantly 100% and have not seen it dropping to normal. also there's only one session scheduled to run at frequency of 30 mins. still see three processes running in parallel and do not see any process getting killed itself once execution completes.

 

let me know please if there any configuration to be done to overcome this issue.

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.