You are viewing limited content. For full access, please sign in.

Question

Question

Printing Excel Workbook with Snapshot

asked on December 10, 2013

 I found references to printing Excel Workbook pages with Snapshot in the old forum:

 

The manner in which the sheets in a workbook are printed is controlled by Excel. There is a setting when printing that lets you choose whether you want to print the active sheet or the entire workbook (in Excel, go to File>Print and you'll see the drop-down under Settings). However, this setting always defaults back to Print Active Sheet - there is no way I've been able to find to have it default to Print Entire Workbook.

So that means if you're trying to use the Generate Pages command for an Excel spreadsheet that has already been stored in Laserfiche (which is basically using Snapshot to "print" the spreadsheet into Laserfiche), I don't think there's a way to select Print Entire Workbook.

However, if you have a spreadsheet that's not in Laserfiche already, you can print it in using Snapshot - open the Excel file, select File>Print, choose Laserfiche Snapshot as the printer and choose Print Entire Workbook in Settings.

If the spreadsheet is already in Laserfiche, instead of using Generate Pages, just double-click the spreadsheet to open it in Excel, then choose to print it back in to Laserfiche using Snapshot. Please note that this will result in 2 separate files (a Laserfiche file and an Excel file) instead of layering them in one file like Generate Pages does, so it might not work for your situation.

 

I opened a 17 page Excel Workbook and printed the whole workbook from outside Laserfiche.  After adding all the information about the server, repository, template, volumes etc.  I finished and sent the document.  After finishing up one of these setup I was given a couple more that I completed also.  It seems that the 1st set of instructions did not cover the whole document.

 

Instead I had 4 documents created.  One with metadata, one with 5 pages, one with 2 pages, and one with 10 pages for a total of 17 pages.  I did this process several times with the same results.  Anyone have any ideas on why this occurs and if there is a remedy?

2 0

Answer

APPROVED ANSWER SELECTED ANSWER
replied on December 10, 2013

This is a known issue with how Excel sends the print job to printers. We don't currently have a fix for it.

0 0
replied on June 24, 2014

Any word on a fix for this?  Thanks!

0 0
replied on August 11, 2014

Have there been any updates to this issue?

0 0
replied on August 11, 2014

Did enabling advanced printing options fix this issue for you?

 

In Windows 7:

Start > Devices and Printers > Right-click on LF Snapshot 8 printer > printer properties > Press "change properties" button at the bottom > advanced tab > check box at the bottom "enable advanced printing features"

0 0
replied on August 12, 2014

Unfortunately it did not work.

0 0
replied on May 2, 2017

Any update on this "known issue"? I am experiencing the same behavior. Printing an Excel document with 9 tabs creates 2 documents: one with 2 pages and one with 7 pages.

0 0
replied on May 2, 2017 Show version history

The only workaround I have found is to open the excel file and do a save as PDF making sure to set the option to save entire workbook.  Then Snapshot the PDF.

 

You can set the Snapshot settings for Document Handling to merge documents with the same name, but I have found that not all sheets print with the same job name.  I guess you could copy the name from the first and then paste it into any following print jobs for the workbook.

0 0

Replies

replied on December 12, 2013

Thanks Miruna!  Is it on your list of "To Do" for future updates?

0 0
replied on January 27, 2014

You should also make sure that the "advanced printing options" is enabled in the LF Snapshot printer properties. I found that when I disabled it, users had problems printing mulitple pages to Snapshot.

0 0
replied on February 26, 2014

Would like to try your "advanced printing options" idea.  But I'm not finding it anywhere in the LF Snapshot printer properties.  Have attached a jpeg.  Thanks.

- LF_Snapshot_Properties.JPG
0 0
replied on February 27, 2014

I found the Enable Advance printing features under the Advanced Tab of the Lf Snapshot 8 Properties after I right click the Lf Snapshot 8 printer icon in Devices and Printers under the Control Panel.

1 0
replied on February 27, 2014

What Jerry said...

 

In Windows 7:

Start > Devices and Printers > Right-click on LF Snapshot 8 printer > printer properties > Press "change properties" button at the bottom > advanced tab > check box at the bottom "enable advanced printing features"

1 0
replied on February 27, 2014

Thanks to both of you.  I'll be forwarding this info to my user to see how it helps things out.

0 0
replied on January 26, 2016

Did anyone ever find a workaround for this?

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.