You are viewing limited content. For full access, please sign in.

Question

Question

Workflow Email Configurator - STARTTLS available as an option?

asked on November 22

Is there an option to use STARTTLS in workflow STMP communications?

0 0

Answer

SELECTED ANSWER
replied on November 22 Show version history

Workflow 10.4.3 uses TLS 1.2 by default. Workflow 10.4.2 and below don't unless you set the .NET Framework and WinHTTP TLS reg keys. That would also be a relevant difference between Forms (which is working) and Workflow (which is not).

Upgrade Workflow to 10.4.3 and see if that fixes the problem.

Edit: https://docs.microsoft.com/en-us/microsoft-365/compliance/prepare-tls-1.2-in-office-365?view=o365-worldwide

For SMTP Inbound mail flow, after deprecation of TLS 1.0 and 1.1, we will accept only TLS 1.2 connection. However, we will continue accepting SMTP Connection which is unencrypted without any TLS. Although we do not recommend email transmission without any encryption.

0 0

Replies

replied on November 22

Yes, Workflow can use SSL connections to the mail server. Check the "use SSL" box in the mail server properties.

0 0
replied on November 22

There is another commend which an app can issue when contacting a SMTP server called STARTTLS (It is not a protocol but a way to ensure the correct protocol is used). While troubleshooting an error returns from Microsoft, Unable to read data from the transport connection: net_io_connectionclosed, IT is asking if the STARTTLS command can be used.

0 0
replied on November 22

Ok, this one is already on port 587 and recently broke so I have a feeling Microsoft is doing something new again (they seem to be at the forefront of SMTP complexity).

I just needed to see if Workflow uses STARTTLS for now so I can get back to IT.

The odd thing is, they have both Forms and Workflow running on the same OS, both are configured exactly the same with the SSL checkbox, port 587, and User/Pass auth.

Forms is allows to send emails and workflow is not. But it was working at once time, so most likely a Microsoft change.

1 0
replied on November 22

Are you trying to connect to Office 365/Exchange Online SMTP?

0 0
replied on November 22

Yup, its the good old smtp.office365.com server.

0 0
replied on November 22

Okay, thanks for confirming.

Are you on Workflow 10.4.3 or higher?

You could also try port 25 with SSL checked in Workflow as Microsoft suggests here for Option 1:

https://docs.microsoft.com/en-us/exchange/mail-flow-best-practices/how-to-set-up-a-multifunction-device-or-application-to-send-email-using-microsoft-365-or-office-365

0 0
replied on November 22

It is version 10.4.2

I tried port 25 with SSL but got the same error.

Does 10.4.3 have a different config option?

0 0
replied on November 22

Can you give us the full stack trace from the logs?

WF uses System.Net.Mail which always sends a STARTTLS command when SSL is used.

0 0
SELECTED ANSWER
replied on November 22 Show version history

Workflow 10.4.3 uses TLS 1.2 by default. Workflow 10.4.2 and below don't unless you set the .NET Framework and WinHTTP TLS reg keys. That would also be a relevant difference between Forms (which is working) and Workflow (which is not).

Upgrade Workflow to 10.4.3 and see if that fixes the problem.

Edit: https://docs.microsoft.com/en-us/microsoft-365/compliance/prepare-tls-1.2-in-office-365?view=o365-worldwide

For SMTP Inbound mail flow, after deprecation of TLS 1.0 and 1.1, we will accept only TLS 1.2 connection. However, we will continue accepting SMTP Connection which is unencrypted without any TLS. Although we do not recommend email transmission without any encryption.

0 0
replied on November 22

Ok will do.

0 0
replied on November 23

That did the trick thanks! Keep running into issues with TLS version mis-matching but I always get thrown off by the error messages.

1 0
You are not allowed to follow up in this post.

Sign in to reply to this post.