You are viewing limited content. For full access, please sign in.



Remotely & Silent Uninstall Laserfiche 10.3 and 10.4 Client

asked on September 17, 2021 Show version history

Does anyone know what the commands to silently and remotely uninstall LF would be? I am able to get it installed, but uninstalling is an issue. I am trying to use PDQ, but I'm sure it'd be similar for other programs as well.


1st step

%SYSTEMROOT%\System32\taskkill.exe /f /im excel.exe
%SYSTEMROOT%\System32\taskkill.exe /f /im msaccess.exe
%SYSTEMROOT%\System32\taskkill.exe /f /im outlook.exe
%SYSTEMROOT%\System32\taskkill.exe /f /im winword.exe
%SYSTEMROOT%\System32\taskkill.exe /f /im lf.exe
%SYSTEMROOT%\System32\taskkill.exe /F /IM wmiprvse.exe
%SYSTEMROOT%\System32\taskkill.exe /F /IM setuplf.exe


2nd step

"C:\Program Files (x86)\Common Files\Laserfiche\Client\SetupLf.exe" /remove /noui -log "C:\logs


The logs are not very helpful:

[PID: 33264] 15:06:20.515  Setup.exe was run with the command line:  /silent /remove /noui /log C:\logs
[PID: 33264] 15:06:20.515  Beginning no user interaction installation.
[PID: 33264] 15:06:20.515  Beginning MSI update check.
[PID: 33264] 15:06:20.515  No MSI update was necessary.

I'm assuming I'm missing a switch or something? I see others tried -silent and the like, but no combination seems to work. It just sits and runs.

1 0


replied on September 21, 2021

Please try using setuplf.exe from the install media not from Common Files.

0 0
replied on September 21, 2021

Hi Miruna, you're saying the removal process has to be done with the original setup media and not through the installed files? How come it works if I manually uninstall through the Control Panel without the original installation media. Does that call upon another process or uninstaller differently?

0 0
replied on September 23, 2021 Show version history

Miruna, to give a little more context.


I am able to install by using this command.


\\SERVER\C$\Deploy\Laserfiche\Current\en\WindowsClient\SetupLf.exe -silent -iacceptlicenseagreement -lang en INSTALLLEVEL=300


This is done remotely by copying the setup file and all the files in the Laserfiche\Current\en\Support\ folder to the C:\Windows\AdminArsenal\PDQDeployRunner\service-1\ folder PDQ uses.


However, when I try to uninstall using this command

\\SPATCH2019\C$\Deploy\Laserfiche\Current\en\WindowsClient\SetupLf.exe /remove /silent /log "C:\logs"


The uninstall hangs. I know you said to make sure and copy all the Laserfiche\Current\en\WindowsClient\ and Laserfiche\Current\en\Support\ files with the setuplf.exe, but that doesn't seem to make a difference. Sits there and runs and runs. 


If I manually run the command from my pc on the files it will uninstall without any issues.


I've attached the logs if that helps at all.





lf_en.msi.txt (738.32 KB)
setup.txt (2.62 KB)
0 0
replied on September 23, 2021

The logs are helpful, but incomplete. It looks like the desktop client, the Admin Console and Snapshot were successfully uninstalled. The Office log is truncated so i can't tell what happened.

To answer your original questions, uninstalling from setuplf.exe in Common Files relies on locally cached copies of the MSI. Sometimes those go missing for whatever reason (reclaiming disk space on a machine that's low on disk, for ex). So since there was not much to go on in your original post, uninstalling using a known good copy would be the first thing to try.

How are you determining that the uninstall failed? Based on the logs, uninstalling Office was still doing work 4 min in.

0 0
replied on September 23, 2021

It doesn't ever fail it just hangs on uninstalling. The setuplf.exe just stays in the task manager at around 32k ram used and will bounce around slightly for as long as you want it to run.


If I run the uninstaller through the command prompt with the same switches and the same files as what are copied down from PDQ it works in less then a few minutes. Everything is uninstalled.


If it helps I can recreate that log if you like. But, it appears to be the same as the past logs it's generated. Perhaps it appears incomplete because I kill the deployment?


I've attached the logs from the successful manual CLI uninstall for you. Perhaps that will give you a better insight?


Also thank you for the info about the MSI's That makes sense about if they somehow get cleaned up for disk space or whatnot.

setup.txt (9.26 KB)
lf_en.msi.txt (738.75 KB)
0 0
replied on September 23, 2021

Hi Miruna,


I actually just noticed something... I am actually having problems with the install as well.

The program installs, but only on pc's that previously had it installed. Otherwise, it will actually fail.

I've attached logs of a successful install. If a failed log from a different pc would help I could provide that as well.

Thanks for all your assistance.



setup.txt (4.02 KB)
lf_en.msi.txt (4.92 MB)
0 0
replied on October 4, 2021

Hi @Miruna Babatie I hate bothering you as I know you are busy, but I thought I would reach out to you to see if perhaps you have had anymore time to look over my replies. I am at an impasse. 


If I can do this without PDQ to all our workstations I'd be open to that option as well. I just need to figure out exactly what to do to get this working.


Thank you!

0 0
replied on October 6, 2021 Show version history

Sorry, we cover these forums as time permits and I got sidetracked. If the matter is urgent, contact your reseller to open a case with Tech Support.

There was nothing useful in your logs. Both sets were indicating that a component of the installer was still going about 4 min after its start.

How long do you wait it out? Does PDQ indicate in any way that it's done?

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.