You are viewing limited content. For full access, please sign in.

Question

Question

Deployment Toolkit: Web Client Configuration Error After Application Uninstall and Reinstall

asked on March 31 Show version history

I have been running tests using the Deployment Toolkit 1.0.4. This has involved running an installation using the deployment toolkit, manually uninstalling each application, and then running the deployment toolkit again to install.

Everything works correctly during the first run, but when I try to run it the second time I receive an error on the "Start configuring WebClient-11.0.0" task. It gives the error "IIS 10.0 Detailed Error - 404.0 - Not Found". Looking in IIS, the virtual directory under the Default Web Site is never created. All the files exist in the Program Files folder though.

What would cause it to not add the virtual directory when running it a second time?

I have been able to replicate this on two different Windows 2019 servers.

0 0

Replies

replied on March 31 Show version history

Thanks for reporting this, Blake. I tried to reproduce on my test environment by uninstalling WebClient first and run the toolkit again, but everything works correctly and not get such "IIS 10.0 Detailed Error".

For trouble shooting , can you provide complete log files under C:\LaserficheDeploymentToolkit\InstallLogs\WebClient-11.0.0 ?

And can you try to manually add an application for the Web client app and check whether there is something wrong in the current test environment?

 

0 0
replied on April 2

I found that there is no install log file for rewrite_2.0_rtw_x64.msi in the attached log files, and I can get the same 404 error when configuring Web client when run deployment toolkit without installing rewrite_2.0_rtw_x64.msi.

 

Please go to Control Panel > Programs and Features, and see if URL Rewrite Module is installed on the machine.

rewrite_2.0_rtw_x64.msi file should be predefined in catalog.json of toolkit scripts and should be found under InstallPackages\en\Support, please double-check the settings.

 

 

0 0
replied on April 2

Yes, IIS Rewrite Module 2 is installed (3/31/2021), but it was installed prior to running the Deployment Toolkit the second and third time (4/1/2021).

The first time the Deployment Toolkit was run the IIS Rewrite Module 2 was not installed previous to running it.

The rewrite_2.0_rtw_x64.msi file is in the Support folder as expected and it is predefined in the catalog.json file.

0 0
replied on April 6

Hi Blake,

The website and virtual directory configuration was done by the installer, not the deployment toolkit. 

Checking the log WebAccess-x64_en.msi.log, it said: 

Disallowing installation of component: WAAppPool since the registry keypath exists and the component is marked to never overwrite existing installations
 Disallowing installation of component: WAIISRedirectComponent since the registry keypath exists and the component is marked to never overwrite existing installations
 Disallowing installation of component: WAIISComponent since the registry keypath exists and the component is marked to never overwrite existing installations

You can check the registry at Computer\HKEY_CURRENT_USER\Software\Laserfiche\WebAccess 11.0, there should be values like "InstalledAppPool = 1". These values should not be present before installing web client.

 

So the issue was that, after the first install, the uninstall did not clean up these registry values correctly, so when the second setup ran, web client installer found the registry values and skips the website configuration.

However I was not able to reproduce the issue: I tried doing the installation/uninstallation on a windows 2019 server, the registry values were cleared as expected.

Can you try uninstall web client, remove the registry values, and manually run web client SetupLf.exe to install, and then uninstall it? Check if the registry values could be cleared with manual install so we could know if it's web client's installer issue.

0 0
replied on April 22

@████████

What about the progress of this issue ?  have the issue gone away with Rui's suggestion? 

 

0 0
replied on April 23

I have not tested deleting the registry entries yet because of the nature of what I needed to do within a specific timeframe. It might be something I can test today though. I will post my results.

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.