You are viewing limited content. For full access, please sign in.



Web Client Login Issue

asked on March 24, 2021

Hi, we are having an issue with logging into Web Client (10.4.2), whenever we attempt to login, it redirects to LFDSSTS for login and redirects back to Web Client, this part is successful but when it comes to loading the folder directory, this just continuously shows it is loading but no folders are being loaded.


We then check the evet log as well as the console in Chrome and can see that an Invalid Connection error with status code 500 is constantly being thrown. The SSL cert we are using is self-signed cert but the cert LFDSSTS is using is a valid cert, but we are not sure if this is what causing the issue. Below is the error in the event log.


Invalid Connection
Operation: /laserfiche/UserSettingsServiceW.ashx/SetLocaleInfo
  Message: Exception encountered, stack trace:
Exception details:
  Message: Invalid Connection
  Stack trace:    at Laserfiche.WebAccess.Common.WARepository.get_SessionAdapter()
   at Laserfiche.WebAccess.Common.UserSettings.Lockdown.GetLockedDownProps(WARepository repo, WAUserSettings settings)
   at Laserfiche.WebAccess.Common.UserSettings.WAUserSettings..ctor(WARepository repo)
   at Laserfiche.WebAccess.Common.UserSettings.TrusteeSettings..ctor(WARepository repo)
   at Laserfiche.WebAccess.Common.UserSettings.WAUserSettings.GetUserSettings(WARepository repo)
   at Laserfiche.WebAccess.Common.Util.SettingsCache.GetUserSettings(WARepository repo, Boolean checkExpired)
   at Laserfiche.WebAccess.Common.ConnectionManager.NotifyTimeZoneChange(Int32 utcOffset, Int32 dstOffset, String dbname, HttpSessionState Session)
   at WebAccessServices.HttpHandlers.UserSettingsServiceW.SetLocaleInfo(String repoName, BrowserLocaleInfo localeInfo)

  Session: 3ganu2ys


Does anyone have any idea? Thanks

0 0


replied on March 24, 2021

Hi Wai Kit Lam,


I discussed this in another post here -


This only impacts 10.4.2 on-wards.


Basically if you use HTTP for web access and not HTTPS then the folder screen never loads, it just sits there with the blue doughnut of death going round and round.


The solution is to switch to HTTPS for WA. You will likely also need to bind your self cert to the default website on 443 if you haven't done that already.


Hope this helps! yes

1 0
replied on March 24, 2021

Hi Chris,


Thanks for the advice, but we are still encountering this doughnut of death issue after installing a valid cert and running SSL, so we are kind of lost as to what is causing the issue.

0 0
replied on March 25, 2021

Hey Wai Kit Lam,


Ah ok, that's the only time I've ever seen this before. I'm assuming this is for all users from all workstations? Have you tried different browsers?


A good test would be to uninstall and install 10.4.1 Web Access/Web Client and see if that resolves the issue, at least you'll know where to start looking.


If that doesn't work perhaps an upgrade to V11 might be the best next step, if it still doesn't work after that then I would go ahead and raise a support case with Laserfiche, so they can troubleshoot this further.

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.