You are viewing limited content. For full access, please sign in.

Question

Question

Can Connector be used on a message box?

asked on October 16

I am trying to set up a Connector profile to run on a modal window / message popup. Unfortunately, I don't think it's going to work, but figured I'd ask.

The reason is to use Connector with a rather old blue-screen application, which doesn't play nice at all. However, I am able to create a macro such that key info can presented in a popup window, which Connector can at least OCR successfully.

I can set up the Connector profile to target the popup and it tests correctly, but after saving the L icon never shows and the shortcut keys don't do anything. If I can get this part working, I think/hope I can extend my macro to also send the key combination to trigger the Connector after popping up the message box.

Any ideas if this can be made to work?

0 0

Replies

replied on October 19

Hi Pieter,

Does the window title change after saving? Sometimes, the window title will change based on the content inside the window. If it is, you can try to use regex in the window title, or selecting "The whole application" under "Apply profile to".

Also, after you finish the profile, if you find that the L icon still does not appear on the window you recorded, firstly, please open the profile you created and record the process name and window title in the profile. Then target the window that does not have the L icon, and see what current process name and window class are. Do they the same?

Thanks,

Tianxia

0 0
replied on October 19

Thank you for the feedback. I'm able to control the message box name and know that it's not changing. If I set it for the whole app the main application will show the L button and I can click the profile while the message box is up. However, I get an error that a modal dialog is blocking the view for Connector.

I think, however, that the issue is that this is coming from an application running within Citrix. I tried a simple script to generate a message box on my machine and Connector could interact with it no problem. So probably an environmental issue. I'm checking to see if I can get Connector running from within Citrix, too (it's not a full Citrix environment, but certain apps run from it).

0 0
replied on October 19

For your reference, this thread discussed about Laserfiche Connector and Citrix: https://answers.laserfiche.com/questions/96872/LF-Connector-and-Citrix#122775

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.