You are viewing limited content. For full access, please sign in.

Question

Question

Unable to create Directory Server licensing site

asked on August 8 Show version history

First time installing Directory Server - Version 10.4.1.127

LFDS Server is Server 2019

SQL Server is 2012 Enterprise Edition (11.0.7462)

Trying to connect to an existing (empty) database using SQL Authentication.  The specified user has appropriate permissions based on what I found in the installation guide.  When I click on 'Attach Site' the error message indicates a SQL error, however there isn't any error being logged on the SQL server.

 

0 0

Answer

SELECTED ANSWER
replied on August 9

Thanks Chase.

The installation guide documentation is not as clear as it probably could be in this case.

I ended up using the sa account to create the initial database and then once I had it setup I changed the connection string in the LFDS settings to use the domain user account running the LFDS service.

2 0

Replies

replied on August 8

Hi John,

LFDS does not support attaching to an empty database currently. We recommend letting LFDS create the database for you with the "create site" button.

If you really want to use an empty database as a starting point, an unofficial method would be to try the "create site" button using your existing empty database as the database name.

2 0
SELECTED ANSWER
replied on August 9

Thanks Chase.

The installation guide documentation is not as clear as it probably could be in this case.

I ended up using the sa account to create the initial database and then once I had it setup I changed the connection string in the LFDS settings to use the domain user account running the LFDS service.

2 0
replied on August 8

Check the LFDS logs on the server for more info. 

Other people with LMO28 were having authentication issues to their SQL server.  Although I would expect SQL to log failed login attempts.  Perhaps your sql server name is incorrect or your LFDS server cannot route to the SQL server?

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.