You are viewing limited content. For full access, please sign in.

Question

Question

Form Lookup Not Working

asked on April 16 Show version history

I have forms using a SQL view that have a rule set to look for employment status and location to fill the inspected field with a list of names from the view.  This has been working fine for months until last week when the AutoFill field stopped appearing and there was no content from the lookup.

Prior exchanges regarding the AutoFill not appearing on copied forms (for version 10.2 https://answers.laserfiche.com/questions/127311/Lookup-Rules-Dont-Work-on-Copied-Form#repliestomain) indicated that deleting and recreating the rule would correct the issue, but this is not the case.  I can't get the inspected field to fill with the secondary criteria of location, but when I remove it and only have a single criteria it fills.  (Doesn't limit my list by the location obviously, but I can at least provide names for selection by the users.)

Why would this start to fail now?  I have not updated to 10.2.1 update 2 yet, but this was working fine until now.  I've refreshed the data source multiple times but it doesn't seem to be working.  It's also showing up on other forms that have multiple criteria for lookups, so this is wider spread than one form.

Looking for an assist, thanks.

4-16-18 lookup.PNG
0 0

Replies

replied on April 16

Hi Michelle,

Do you have any idea what might be changed last week? The Forms process? The lookup database columns?

For the other forms that are experiencing this issue, are they using the same lookup data source?

Have you tried creating a new process, use a different data source, and try if lookup match multiple criteria works?

0 0
replied on April 17

Rui nothing changed in the Forms process or the lookup database columns.  Only thing that changed was the access rights to the forms.  I added new groups.

Yes all of the forms having the issue are using the CombinedHRADEmployee lookup table and view.  (I've tested using both.) That table exists in the same database as other tables being used in the lookup rules for each of these forms.

Any changes in the column names would have been addressed when I deleted and recreated the rules because I would have identified the changed column titles.

Testing new process with same table and with different table for multiple criteria.  I will update you when I get results.

0 0
replied on April 17

I tested with a new form using both the same table and a different table with multiple criteria and it worked.

So I went back to my original forms which were still not working, deleted the original rule and recreated them.  They are now working.

There was no change to the DB other than content in the table, no change to the form business process or lookup rules, but the lookup rules did not work until I recreated them.

I know I am due for the upgrade, this may be more of a push for that to happen soon!  Any other thoughts as to why this may have happened or a way to prevent it, please let me know.

0 0
replied on April 17

Actually we have never got such kind of issue so we have no idea how to prevent it. Can you check the event viewer for error logs and see if there was any error related with lookup rules? 

Besides, how many times did you recreated the rules? It seems to me that you had recreated them in the first reply but then you recreated them again in the second reply, and this time the issue was resolved?

0 0
replied two days ago Show version history

I checked the event viewer and the only errors I found related to the time I was experiencing the error are those indicated in the screen shot.

I recreated the rules two times for two of the forms.  The others I left with the original rules which, when I went back in yesterday were still not working until I deleted them and recreated them.

4-18-18 lookup.PNG
0 0
replied two days ago

If there is still form where lookup could not work, can you open a support case and provide us your Forms database and lookup database? We can check the db and see if we can find anything that went wrong.

0 0
replied one day ago

I think I got all the forms but will do a sweep to see if there are any that I can send you.

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.