You are viewing limited content. For full access, please sign in.

Question

Question

Unable to install ASP.NET 4.5 in Windows DataCenter 2016

asked on January 26, 2017 Show version history

Has anyone done an install onto Windows Data Center 2016?  I am having trouble finding a way to install the ASP.NET 4.5 prerequisite to continue the install.

 

Any help would be greatly appreciated.Thank you!

0 0

Replies

replied on May 2, 2018

Our customer is having the same issue in Windows Server 2016 Standard.  We installed the ASP.NET 4.6 feature in Server Manager, but the LFDS installer isn't satisfied.

Raymond Cruz with LF Support recommended we bypass the requirement, but after doing so, the LFDS site doesn't work, giving an HTTP error.

Raymond provided this blog post, citing Solution 7:

https://blogs.msdn.microsoft.com/webtopics/2010/03/08/troubleshooting-http-500-19-errors-in-iis-7/

However, Solution 7 indicates that an ASP.NET dependency is missing, see last paragraph of solution.

 

LF Support then recommended we uninstall .NET, and install .NET 4.0, 4.5.2, and 4.7.2 in order, to make sure components and dependencies were properly installed.  This doesn't make sense, because you can't uninstall the embedded .NET 4.6 from Server 2016, nor should previous versions of 4 be necessary.

Looking for ideas?

2 0
replied on May 2, 2018

We found this article, and after using the first resolution (using DISM to install .NET 4.5), the installer  was happy and we could proceed.  We can now see the licensing site and configure it.  I suggest this appears to be a bug or deficiency for the LFDS installer in a Windows Server 2016 environment.
https://support.microsoft.com/en-us/help/2736284/how-to-install-asp-net-4-5-on-windows-8-and-windows-server-2012

3 0
replied on March 12

This worked for me where none of the other solutions on this thread worked. Thanks Cameron!

 

2 0
replied on June 4

This also worked for me with the /all switch.

dism /online /enable-feature /featurename:IIS-ASPNET45 /all

 

THANKS Cameron!!

1 0
replied on January 27, 2017

Hi Steve,

 

I'm not 100% sure but I don't think you can install ASP.NET 4.5 on 2016, it has to be 4.6 or higher..... frown

 

Probably a question better placed on the MS forums wink

1 0
replied on January 27, 2017 Show version history

ASP.Net is a feature under the .Net framework in Windows 2016. And Chris is right, it's .NET 4.6:

Edit May 2, 2018:

On newer versions of 2016, there is also a ASP.Net checkbox under IIS.

1 0
replied on March 5, 2018

Do we need ASP.NET 4.5 or can we just install ASP.NET 4.6 and call it good?

 

 

0 0
replied on March 6, 2018

4.6 is fine.

1 0
replied on May 2, 2018

4.6 is not satisfying the requirement in our case, installing LFDS on Server 2016.

0 0
replied on May 2, 2018 Show version history

What exactly do you have installed under .Net 4.6 in Windows?

Actually, it looks like the latest updates to Windows 2016 brought back the second checkbox and you now also have to check  ASP.Net 4.6 under IIS.

0 0
replied on July 17, 2018

@████████

We are the client that @████████is talking. The box was marked for ASP.NET 4.6, but the installer still didn't accept 4.6 in place of 4.5.

We had to use DISM, as mentioned below, to get around it. Do you know if this has been fixed in the latest update of 10.3.1? I'm about to start installing Rio on new servers.

0 0
replied on March 16, 2018

I'm in this same situation with a client. I have 4.6 installed but Forms Essentials and Web Client is not recognizing that ASP.NET 4.5 is installed as a prereq. Is this a known issue? I'm assuming Laserfiche is considering this a Microsoft issue?

0 0
replied on July 4, 2018

Hi,

What is the official approach to this problem ? We are looking at installing Laserfiche Rio on a Windows R2016 server.

0 0
replied on July 17, 2018

I don't think there is one unless its been fixed in the latest version of 10.3.1. I'm about to find out this week when we begin our install.

0 0
replied on August 10, 2018

I was having similar issues while installing Laserfiche Workflow 10.2 on a Windows 2016 Server.  After reading this post, I found that installing ASP.NET 4.6 under Weber Server-->Application Development allowed the prerequisite for ASP.NET 4.5 to succeed. 

 

The version of Laserfiche RIO I installed it from is 10.3.1.181_20180731. So maybe the problem is now resolved.

0 0
replied on August 10, 2018

Maybe for the Workflow Installer was updated, but I didn't have a problem with that one. I believe it was LFDS and LFS that gave me issues.

0 0
replied on August 10, 2018

All our installers use the same logic. Nothing changed in Workflow for 10.2.1.

We check HKEY_LOCAL_MACHINE\Software\Microsoft\Net Framework Setup\NDP\v4\Full for the Version value to see if .Net is installed and (on Windows 8 or higher) HKEY_LOCAL_MACHINE\Software\Microsoft\InetStp\Components for the ASPNET45 value to see if ASP.Net is installed for IIS.

0 0
replied on August 10, 2018

@████████, can you confirm LF has tested these installs against a fresh Server 2016 installation with ASP.NET 4.6 installed using the server features tools in Server Manager?

I've done it 4 times in the past 3 months and it doesn't work. 4.6 is supposed to be compatible with 4.5.

0 0
replied on August 14, 2018

We have.

Can you run the installer with logging enabled and send the log to Tech Support so we can see what is different?

setuplf.exe -log c:\temp

The folder should be created first. The installer will create multiple logs in there. Just zip them up and ask your reseller to open a case.

0 0
replied on August 16, 2018

I'll ask our server team if they would be willing to spin up a test VM for this.

0 0
replied on December 4, 2018

Any updates to this post?  The installer still fails to pass the prerequisite checklist for .NET 4.5 on Server 2016.  This occurs with the Avante suite also when installing any web services.

0 0
replied on December 4, 2018

If you are sure you checked the .Net features under both ".Net framework" and "web server" features in the Windows installer and the registry keys mentioned above exist, then please run the Laserfiche install with the logging options above and have your reseller open a case with Tech Support.

0 0
replied on December 11, 2018

I know we enabled both, but our IS team isn't up for creating another VM just for this issue now that we are live and had our own work around (force 4.5 install on top of the 4.6 that's already included).

0 0
replied on March 4 Show version history

I ran into a similar issue and was able to fix it with this configuration. 

Originally I only had ASP.NET 4.6 under Features and it wasn't detecting ASP.NET 4.5 as a prereq. So I added:

1. ASP.NET 4.6 under Server Roles>Web Server>Application Development

 

2. ASP.NET 3.5 under .NET Framework 3.5 Features (for good measure)

 

Then the prerequisites went through

 

1 0
You are not allowed to follow up in this post.

Sign in to reply to this post.