You are viewing limited content. For full access, please sign in.



Object locked - The operation cannot complete because an object is locked. [9045]

asked on May 1, 2014

We upgraded from Laserfiche Avante 8.3 to Laserfiche Avante 9.1 back in March 2014.


We have a main “Vendors” folder that currently has 5,315 subfolders—one for each vendor number. Within each vendor number folder is a set of up to 6 subfolders.



All subfolders under the “Vendors” folder are inheriting rights from their parent folder with the rights originating at the “Vendors” folder.


Since we’ve upgraded to Laserfiche Avante 9.1, I have been unable to add or remove rights on the “Vendors” folder.


The three times that I have tried, the Laserfiche Client hangs and becomes unresponsive. This is then followed by the following error message.



Object locked.
The operation cannot complete because an object is locked. [9045]


We checked the “Activity > Entry Locks” section in the Administration Console, but there were no locked entries.


All users who try to navigate the repository after we first get the above error message get a sluggish response that eventually leads to them getting the same error message.


We didn’t have any issues adding or removing rights in Laserfiche Avante 8.3.


The “Vendors” folder is the one folder within our repository that has such a large number of subfolders. All other folders generally have only a handful of subfolders. Adding or removing rights on other folders does not result in this error message.


Oddly enough, we were able to run Workflows on two separate occasions to remove rights from the “Vendors” folder, and the Workflows completed successfully.


The easiest way to clear up this issue has been to reboot the Laserfiche server, which clears out the “lock” and returns the repository functionality back to the way that it was before the error message.


Unfortunately, I am leery of attempting to add or remove rights from this folder again, as I’m confident that we’ll get the same error again.


Any ideas on what might be causing this issue and a possible solution? Has this been reported by any other users?

0 0


replied on May 1, 2014

Hi Faron,


Please confirm whether you are using Laserfiche Server 9.1.0 or 9.1.1. You can check the version of C:\Program Files\Laserfiche\Server\lfs.exe to get that information.


If you are using Laserfiche 9.1.0, then I would recommend upgrading to Laserfiche 9.1.1. In the list of changes for Laserfiche 9.1.1 you'll note that it states

Changing entry access rights on a folder with many descendants is now less resource intensive. (111351)


I believe that may be the cause of your issue. However, if you are already using Laserfiche Server 9.1.1, then I would recommend contacting your Laserfiche reseller to open a support case.



1 0
replied on May 1, 2014

Thank you for the quick response, Alexander!


We are, in fact, running Laserfiche Server 9.1.0.


I will pass the information to my IS Team that shows that this issue has been resolved with the 9.1.1 release.


Thanks again!

0 0


You are not allowed to reply in this post.
You are not allowed to follow up in this post.

Sign in to reply to this post.