You are viewing limited content. For full access, please sign in.

Question

Question

Quick Fields without local administrator rights in Windows 7

asked on February 11, 2014 Show version history

I have recently upgraded our Quick Fields 8.3 scanning station to Windows 7. Quick Fields is requesting administrator rights just to open the application. The IT security policy prohibits local administrator rights; it also prohibits disabling User Access Controls (UAC). 

 

  1. How can Quick Fields be used without local admin or UAC disabled?
  2. Why are these elevated permissions required in Quick Fields, but not when using Laserfiche Scanning?
  3. What is the minimum access required to (specific files/folders if necessary) for users to utilize Quick Fields using Windows 7?
  4. Is the information found in this thread accurate?

Here's what I've been told from LF Support in the past.

 

Windows rights needed for Laserfiche Scanning

 

Local admin

-No additional rights needed

 

Windows Power User

-Full rights to "setscan.ini" file in the Windows folder (Other option is to give full rights to the Windows folder)

 

Windows User

-Full rights to "setscan.ini"

-Full rights to Hkey_Current_user\Software\Laserfiche

-Full rights to users Temp folder.

 

A properly coded application should not require administrator rights just to run in Windows 7. This doesn't happen with other scan software I've used. Please advise.

 

(Edit: Fixed forum link)

(Edit: Added portion of forum post I was specifically asking about)

1 0

Replies

replied on November 19, 2014 Show version history

I was looking for a solution to this and ran across this thread.  I wanted to have the normal user operate under a limited account and keep UAC on.  This didn't come from LaserFiche and I haven't tested it thoroughly but seems to work:

Remove the " (x86)" if you're using 32 bit Windows for all the following instructions.

Grant the "Users" group "Modify" permission to c:\Windows\SETSCAN.ini as well as C:\Program Files (x86)\Laserfiche\

 

Open notepad and paste in this text:

set __COMPAT_LAYER=RunAsInvoker
start "" "C:\Program Files (x86)\Laserfiche\Quick Fields 8.0\Laserfiche.QuickFields.exe"

 

Save that as StartQuickFields.bat in  "C:\Program Files (x86)\Laserfiche\Quick Fields 8.0\"

Delete the normal desktop shortcut for QuickFields and create a new shortcut to the StartQuickFileds.bat file.  Rename the shortcut to "Quick Fields".

Right click that new shortcut and select properties.  Change the "Run:" option to Minimized then click "Change Icon".  Browse to "C:\Program Files (x86)\Laserfiche\Quick Fields 8.0\" and select the QuickFields.ico file.

At that point you should have a desktop icon that looks like the normal Quick Fields icon but without the UAC shield.  From there it should work as usual without an elevation prompt when a user clicks it.

I may have been overly verbose in the explanation but it takes 2 minutes to impliment.  Scanning and other typical functionality seems to work fine in my limited testing.

3 0
replied on November 19, 2014

Wow, that's great!

1 0
replied on February 11, 2014 Show version history

I can't open the topic you linked to, so this might be the same one:  https://support.laserfiche.com/forums.aspx?Link=viewtopic.php%3ft%3d15877%26amp

 

Essentially the issue is with the scan engine underlying the OCR components of Quickfields. Some of those components need to write to c:\windows and you can either give local admin rights or turn off UAC to allow this. 

 

The person responding on that thread (Miruna) is a developer with Laserfiche. 

 

 

0 0
replied on February 11, 2014

2. Why are these elevated permissions required in Quick Fields, but not when using Laserfiche Scanning?

 

Same question. OCR is available in LF Scanning. What is different?

0 0
replied on February 11, 2014

I suspect the reason it's hard coded to c:\Windows for some things is because Quick Field sessions also need to potentially be able to run under SYSTEM when running Quick Fields Agent. I think Laserfiche Scanning uses the same settings but is programmed to use your normal user spaces because they are always run interactively. 

 

A Laserfiche developer might be able to explain the specifics. 

0 0
replied on February 14, 2014 Show version history

I tried running as a power user with access to the setscan.ini file as well as the programdata\Laserfiche folder.

 

I can open Quick Fields and a session, but I still have 2 problems:

  1. I can't see or access mapped network drives from the Open screen within Quick Fields. Since our session files are stored on the network, it is a problem. I can access the network folders by typing in the network path (no letter).
  2. I have to enter my password at the elevation prompt to open Quick Fields

 

Does anyone have any tips? I know I'm not the only one that works somewhere with tight regulations/controls over local administrator rights....

0 0
replied on February 16, 2014

For #1 you could try mapping a drive letter. 

0 0
replied on February 18, 2014

Edited... "can't see drive letter"

0 0
replied on February 24, 2014

Is anyone from Laserfiche able to answer my questions?

0 0
replied on November 9, 2015

Aside from the batch file option is there any "official" answer to this? We have a client who must use the "Run as administrator" option as otherwise the images do not load in Quick Fields. They have asked for a more granular approach to modifying security rather than grant local admin rights.

0 0
replied on November 9, 2015

I'm not sure but for what it's worth we haven't had any negative implications from launching QuickFileds with the above script for a year now.  If there's any obscure functionality that is broken by it we havne't discovered it yet.

1 0
replied on November 9, 2015

Thanks Jeff - the batch file remains an option, just curious to know what exact rights and to which locations we needed access. Everything works except the images don't display after processing via the LFCE so guess it must be that folder but not in the office to check myself.

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.