I can not find any documentation explaining what Error 35 is when verifying a new data source connection in Cloud.
Question
Question
Answer
This error is coming directly from your SQL Server. One cause could be that the certificate on your SQL Server does not match what is available in Cloud. https://doc.laserfiche.com/laserfiche/en-us/content/pa-in-ds-ovw.htm
We have additional documentation and expanding out these errors coming soon.
Oh I see, the error is being passed through from SQL. I also can't find a document from Microsoft on this, just want to confirm exactly what the problem is, if it is a cert is it the expiration date, the authority, etc so I can inform them exactly what is wrong. I am having them check the event viewer and try without encryption. Thanks for the tip.
One recommendation would be to differentiate if the error is coming from Laserfiche or Microsoft since we just expected the error was coming from Laserfiche.
It was the SQL Service not being able to access the cert.
Replies
Hi,
I actually ran into this issue last year. In the end it was our firewall blocking the connection. It may be worth getting together with your network admin and making sure traffic is allowed.
In that case we would not have been able to establish a connection with the server. This error code is for a certificate issue, not for an inability to reach the server.
I looked over the posts and the first post includes the same problem, error 35 but successfully establishing a connection with the server, but it was left unresolved with Andrew stating it is likely a cert issue.
The second post made no mention of error 35 or successfully establishing a connection with the server.
The reason it can not possibly be a firewall is because a firewall is at the network level which is on the road to the server, not on the server itself. If the road is closed we would not be able to reach the server to begin with. Once we get there and we have a problem, we know the problem is no longer on the road.
In this case we reached the server, we were even able to perform a handshake and say hello but the server told us error 35. This was what Kevin was informing us; the error 35 was not a statement from Laserfiche, it was a statement received from Microsoft SQL on our arrival.
So I am going to focus on the cert while we are there, rather than going back to look for potholes in the road.
I found the customer is using an IP for their server name and that feels like the problem as certs are designed for domain names to ensure they resolve to the correct IP. I am asking them to switch to using the domain they bought their cert for.