You are viewing limited content. For full access, please sign in.

Question

Question

Failed to publish workflow 'MMECM.Checks.Posted': Object reference not set to an instance of an object. [0411-WF0]

asked on May 15

Without any obvious warning, we could not publish a workflow rule we were editing. The rule had been published successfully, it is not a new rule.  The error is:

Object reference not set to an instance of an object.

---Stack Trace---

 

Client trace

   at Laserfiche.Workflow.Objects.WorkflowObject.Create(Stream activityStream, WorkflowPublishingOptions options)

   at Laserfiche.Workflow.Designer.PublishWorkflowAction.PublishWorkflowToServer(TempFileStream designerWriter)

   at Laserfiche.Workflow.Designer.PublishWorkflowAction.InnerPublish()

   at Laserfiche.Workflow.Designer.PublishWorkflowAction.InnerPublishWithProgress()

   at Laserfiche.Workflow.Designer.PublishWorkflowAction.Execute()

With the error posted as:

 

The services runs under the account blacked out, and since the file it wants is in users, it has permissions.  

Maybe it's a problem with the rule.  Well, we created an empty rule and it would not publish either. It gave us the same error. It feels like a support case, but I thought I would throw it up here first, to see if anyone has any ideas.

0 0

Replies

replied on May 15

Are the Designer and Server on the same version? 

Can you right-click on the Help button and choose "Copy Diagnostic Data" so we can see the full error?

Is this through remote desktop? If yes, is the blacked out section of the path just a user name or username followed by a single digit folder?

Is there an anti-virus that could be scanning the files in the temp folder and keeping them locked or moving them away as quarantined?

0 0
replied on May 18

Hi Miruna - We tried two Designer instances, one that was separate on a machine other than the WF Server.  The blacked out name was the service account, i.e. the user name.  I'll get the diagnostic data and check on the anti-virus. Thank you.

0 0
replied on May 18

Update- rebooting the server resolved the problem.  It was just a glitch in the matrix.

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.