You are viewing limited content. For full access, please sign in.

Question

Question

Administration Hub - Cannot get server list

asked on January 27

What do you do if you see this message on the Servers tab but the service is running? Can we get more informaiton?

0 0

Replies

replied on January 28

Hi Chad,

Could you check Admin Hub logs to see if there is more detailed error message? They are located at:

  • C:\ProgramData\Laserfiche\AdminHub\Logs\AdminHubLog_w3wp.log
  • C:\ProgramData\Laserfiche\AdminHub\Logs\AdminHubLog_Laserfiche.AdminHub.AgentController.Host.log

 

Best,

Ziyan

1 0
replied on February 23

It's an object reference error. Someone created a variable and forgot to set it in the code.

Object reference not set to an instance of an object.
   at Laserfiche.AdminHub.Core.Cache.LFDSRegistrationCacheService.GetServerRegistrations(Boolean extendExpirationTime)

0 0
replied on February 23

Can we get the full stack trace for the error?

0 0
replied on February 23
Caught exception: System.NullReferenceException
Message: Object reference not set to an instance of an object.
   at Laserfiche.AdminHub.Core.Cache.LFDSRegistrationCacheService.GetServerRegistrations(Boolean extendExpirationTime)
 
2026-02-18 08:32:32.6201||ERROR|AdminHubLogs|16|--- 2026-02-18T16:32:31.7944530Z AHWebContext started.
[+444ms][ERROR][Thread-16] An error occurred while sending the request.
Stack Trace:
Caught exception: System.Net.Http.HttpRequestException
Message: An error occurred while sending the request.
   at Laserfiche.AdminHub.Core.AgentController.AgentControllerApiClient.ExecuteUnderWindowsContext(Action action)
   at Laserfiche.AdminHub.Core.AgentController.AgentControllerApiClient.<GetAgentRegistrations>d__5.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at Laserfiche.AdminHub.Web.WebAPI.AgentRegistrationController.<Get>d__4.MoveNext()
Inner exception: System.Net.WebException
Message: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.
   at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
   at System.Net.Http.HttpClientHandler.GetResponseCallback(IAsyncResult ar)
Inner exception: System.Security.Authentication.AuthenticationException
Message: The remote certificate is invalid according to the validation procedure.
   at System.Net.TlsStream.EndWrite(IAsyncResult asyncResult)
   at System.Net.ConnectStream.WriteHeadersCallback(IAsyncResult ar)
[+824ms][ERROR][Thread-16] AHWebContext operation successful.

 

0 0
replied on February 24 • Show version history

Hi Chad,

You may ignore the NullReferenceException error, it is a known issue(644685) but it won't affect the site loading.

 

The error on the page should come from the second error, AdminHub site complained about connection error with Agent Controller (default port 7055). 

Could not establish trust relationship for the SSL/TLS secure channel.

 Please check what certificate is binded on 7055 and change to one that trusted by the server. AdminHub Utility ("C:\Program Files\Laserfiche\AdminHub\AgentController\Laserfiche.AdminHub.AdminHubUtility.exe") can be used to update the Server certificate used.

1 0
replied on January 27

What version are you using? Recent versions have fixed a few bugs in Administration Hub. Laserfiche 12 Changelog

0 0
replied on January 27

The installer says the latest build is 20365 for a full build number of 12.0.2509.20365. Build 629959 does not seem to exist. Not sure how this changelog correlates with build numbers.

0 0
replied on February 24

The latest version should be 12.0.2509.2.365. You can check it on https://doc.laserfiche.com/laserfiche.documentation/12/userguide/en-us/content/intro-release-information.htm?tocpath=Laserfiche%20User%20Guide%7CLaserfiche%2012%20Release%20Information%7C_____0

 

629959 is an internal id tracking the issue we fixed.(In this case, it refers issue in Laserfiche AI Service)

 

0 0
replied on February 24

They opened this utility up and it was already set with a valid cert. I think the installation prompts you to do this from the start.

0 0
replied on February 24

Yes, it will ask to configure the cert for Agent Controller. However, the log shows AdminHub Site cannot establish SSL connections with Agent Controller. What is the certificate look like? Is it a wildcard certifiacte? The certificate should match the Agent Controller's FQDN name configured in the utility.

0 0
replied on February 25 • Show version history

Ok I see. They were using the host name for the machine rather than the certificate domain. They updated to the domain in the certificate and now they get this error

Agent Controller

2026-02-25 10:00:34.5174||ERROR|AdminHubLogs|4|--- 2026-02-25T18:00:34.5024020Z
[+13ms][ERROR][Thread-4] Laserfiche Administration Hub encountered a SCP error. [LFAH3800-SCPError]
Details:
URL: 
Error: SCPError
Date: 2/25/2026 10:00:34 AM (Pacific Standard Time)
HTTP Status Code: 500
Stack Trace:
Caught exception: Laserfiche.AdminHub.Utils.AdminHubException
Message: Laserfiche Administration Hub encountered a SCP error. [LFAH3800-SCPError]
Inner exception: System.Runtime.InteropServices.COMException
Message: The specified domain either does not exist or could not be contacted.
   at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)
   at System.DirectoryServices.DirectoryEntry.Bind()
   at System.DirectoryServices.DirectoryEntry.get_AdsObject()
   at System.DirectoryServices.PropertyValueCollection.PopulateList()
   at System.DirectoryServices.PropertyValueCollection..ctor(DirectoryEntry entry, String propertyName)
   at System.DirectoryServices.PropertyCollection.get_Item(String propertyName)
   at Laserfiche.AdminHub.SCPUtility.SCPHelper.UpdateSCP(String path, String port, String host)
   at Laserfiche.AdminHub.SCPUtility.SCPHelper.PublishSCP(String url)
   at Laserfiche.AdminHub.AgentController.Host.AgentControllerHost.PublishSCP(String url, IAdminHubLogger logger)
 

Agent Hub

2026-02-25 10:00:40.7777||ERROR|AdminHubLogs|11|--- 2026-02-25T18:00:40.5421865Z AHWebContext started.
[+229ms][ERROR][Thread-11] [CreateExceptionFromResponseErrors]: HTTP status code: Unauthorized.
[+231ms][ERROR][Thread-11] Object reference not set to an instance of an object.
Stack Trace:
Caught exception: System.NullReferenceException
Message: Object reference not set to an instance of an object.
   at Laserfiche.AdminHub.Core.AgentController.AgentControllerApiClient.<CreateExceptionFromResponseErrors>d__13.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1.ConfiguredTaskAwaiter.GetResult()
   at Laserfiche.AdminHub.Core.AgentController.AgentControllerApiClient.<GetAgentRegistrations>d__5.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at Laserfiche.AdminHub.Web.WebAPI.AgentRegistrationController.<Get>d__4.MoveNext()
[+234ms][ERROR][Thread-11] AHWebContext operation successful.

And to clarify the obvious, the domain does resolve to the machine's local IP address and not some other machine.

0 0
replied on May 26

Getting more and more reports of this same error from other clients. Just looked at another one where no errors are being logged to the programdata folder.

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.