You are viewing limited content. For full access, please sign in.

Question

Question

Can browser autofill be disabled at the form level?

asked on June 10

I've seen a few similar posts to this but don't see a clear answer. We've had an issue pop up where a manager is signing a form, and the Edge browser's autocomplete is not only filling in his name for the signature field, but also changing some amounts further up on the form (highlighted numbers in the screenshot below). Worse, these are above the part of the form that is visible so it's not at all obvious to the user.

I need to get this disabled so managers aren't inadvertently changing amounts to whatever it was when the browser saved their typed name in the signature field.

NOTE: this environment is still on 10.4.5. There are plans to get things updated to 11 this fall.

2 0

Replies

replied on June 10

@████████ have you encountered this? I think it's part of the new Microsoft Wallet functionality in Edge.

I managed to recreate the issue. It saves automatically without prompting and I can't even see the saved data in the wallet.

0 0
replied on June 10 Show version history

Not personally.

You might give this attribute a spin for the field(s) in question:

autocomplete="off" 

MDN Web Docs: How to turn off form autocompletion

W3 Schools - How To - Turn Off Autocomplete For Input

Do let us know if it's reproducible in 11 when you get a chance.

Edit: Apparently plain 'autocomplete="off"' doesn't reliably work in Edge but 'aria-autocomplete="none"' does. See:

https://stackoverflow.com/questions/32785958/disable-input-text-suggestions-in-edge/73691203#73691203

https://developer.mozilla.org/en-US/docs/Web/API/Element/ariaAutoComplete

https://caniuse.com/?search=aria-autocomplete

See also: https://caniuse.com/input-autocomplete-onoff

0 0
replied on June 10

This is a comment to trigger subscriber notifications for the edits I made above.

0 0
replied on June 10

Thanks, Sam. I'll check this out.

1 0
replied 16 hours ago

I think this will work, at least for this particular case. For each form in the process I added the JS

$('input[type="text"]').attr('aria-autocomplete', 'none');

It's all testing just fine so I'll add it to production this week. I thought the JS might prevent some of the lookup autocompletes, but those all continued to function properly.

Hopefully the issue is limited to this process, but I fear it won't be. That new Wallet functionality in Edge is very aggressive about storing and auto filling and it stores silently. I fear for what happens if this causes issues with forms built in the New Designer in v11, where JS like that won't function.

1 0
replied on June 10

This doesn't solve the root of the problem, but here's the JS we were using in v10 to detect if the browser was Internet Explorer. We were redirecting to a screen that just told them which browsers to use instead.

/*Added code to detect if user is opening from IE.  If so, redirect to Incompatible Browser form*/
var isIE = document.documentMode;

if (isIE) {
  window.location.replace("https://formsportal.siumed.edu/Forms/incompatible_browser");
};

 

0 0
replied on June 14

We've been trying to chase something down in autocomplete too.  If a form is filled out using autocomplete then a calculation in another field that references that value returns 0.  Edit the autocomplete value, remove on char to the right and it works!  The other case we had was a form filled out using autocomplete failed every time on save, did not create a business process at all.  We finally realised it was autocomplete but the issue went away and everything's been fine since.

 

We're trying to track down the details to raise a case but its no easy to capture the evidence they need.

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.