You are viewing limited content. For full access, please sign in.



Root Element is Missing on Forms Server Config Page//500 Internal Service Error from Workflow

asked on June 7

Self-Hosted // Separate Forms and Workflow servers. The main issue I am having is I have a workflow with a Retrieve Business Process Variables activity that gives me a 500 Internal server error when I try to configure the fields being retrieved. 


When I try to configure the Laserfiche server from workflow I get a similar error. 



I also noticed this error "Root Element is missing" on the forms server configuration page of the formsconfig and I am unable to save any changes to the fields on this page (they are all blank). 

This error looks pretty rare for answer but I wanted to give it a shot here just in case someone has seen this before. 

0 0


replied on June 7

Seems like a Forms server misconfig. Was it ever fully setup and functional? If not, it should do no harm to do a full reinstall of the Forms server. No point in trying to setup your workflow to work with your Forms server if the Forms server isn't working.

1 0
replied on June 7

Yes this config has been around for years with active forms submissions. The only thing that appears to be effected is retrieving business process variables. 

0 0
replied on June 7

Have you checked the Forms event logs? There might be an error corresponding to that 500 with more information.

0 0
replied on June 7


An unexpected error has occurred. [LFF502-UnexpectedError]

URL: /FormsConfig/Configuration/GetFormsServerInfo
Error: UnexpectedError
Date: 6/7/2024 2:41:04 PM (Eastern Standard Time)
HTTP Status Code: 500
Business Process ID: 0
User: XXXX
Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Stack Trace:
Caught exception: Laserfiche.Forms.CommonUtils.Exceptions.LFFormsException
Message: An unexpected error has occurred. [LFF502-UnexpectedError]

Inner exception: System.Xml.XmlException
Message: Root element is missing.
   at System.Xml.XmlTextReaderImpl.Throw(Exception e)
   at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
   at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
   at System.Xml.XmlDocument.Load(XmlReader reader)
   at System.Xml.XmlDocument.Load(String filename)
   at FormsConfig.Infrastructure.FormsServerInfo.SaveAPIConfigFile(Boolean IsWorkflowSSL)
   at FormsConfig.Infrastructure.FormsServerInfo.ReloadCache()
   at FormsConfig.Infrastructure.FormsServerInfo.get_Current()
   at FormsConfig.Controllers.ConfigurationController.GetFormsServerInfo()
   at lambda_method(Closure , ControllerBase , Object[] )
   at System.Web.Mvc.ControllerActionInvoker.InvokeActionMethod(ControllerContext controllerContext, ActionDescriptor actionDescriptor, IDictionary`2 parameters)
   at System.Web.Mvc.Async.AsyncControllerActionInvoker.<>c.<BeginInvokeSynchronousActionMethod>b__9_0(IAsyncResult asyncResult, ActionInvocation innerInvokeState)
   at System.Web.Mvc.Async.AsyncResultWrapper.WrappedAsyncResult`2.CallEndDelegate(IAsyncResult asyncResult)
   at System.Web.Mvc.Async.AsyncControllerActionInvoker.EndInvokeActionMethod(IAsyncResult asyncResult)
   at System.Web.Mvc.Async.AsyncControllerActionInvoker.AsyncInvocationWithFilters.<>c__DisplayClass11_0.<InvokeActionMethodFilterAsynchronouslyRecursive>b__0()
   at System.Web.Mvc.Async.AsyncControllerActionInvoker.AsyncInvocationWithFilters.<>c__DisplayClass11_2.<InvokeActionMethodFilterAsynchronouslyRecursive>b__2()
   at System.Web.Mvc.Async.AsyncControllerActionInvoker.EndInvokeActionMethodWithFilters(IAsyncResult asyncResult)
   at System.Web.Mvc.Async.AsyncControllerActionInvoker.<>c__DisplayClass3_6.<BeginInvokeAction>b__4()
   at System.Web.Mvc.Async.AsyncControllerActionInvoker.<>c__DisplayClass3_1.<BeginInvokeAction>b__1(IAsyncResult asyncResult)

0 0
replied on June 7

Do you have the Workflow Web Service configured to use SSL?

Do you have the configuration of the Workflow connection in the FormsConfig set to use SSL?

0 0
replied on June 7

I fiddled with SSL as well. It was SSL and I turned it off and same result. I turned it back on and same result.

Nothing on the page "FormsConfig#/forms" is saving. The message is "root element is missing". I suspect that the underlying data that that page pulls data from has a problem. Is it a web.config? This is a complete guess. 

0 0
replied on June 7

The Workflow web service does not come into play when configuring Workflow to talk to Forms. It's only used when Forms talks to Workflow.

SSL is also not the issue here, we would see a different error.

Kevin is on the right track, there is something wrong with the Forms Server's configuration. The stack trace indicates it can't save changes to the Forms API configuration (which is what is used when Workflow calls in and results in the 500 error).
I would take it to Tech Support so we can take a closer look.

1 0
replied on June 10

I'm unsure if this is related, but we experienced the same error in Workflow when we disabled Anonymous Authentication in IIS. We had to re-enable it to reestablish the connection between our Workflow and Forms servers.

0 0
replied on June 10

This needed a Forms reinstall to fix. I am not exactly sure what happened. I don't think it happened out of the blue. I think it was a result of a configuration change made weeks ago and Forms could do everything it needed to do until one specific workflow needed to consume a business process variable. 

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.