You are viewing limited content. For full access, please sign in.



Workflow error - Input is not a valid Base-64 string

asked on July 18, 2023

I recently installed the latest version of Workflow Designer (11.0.2306.898) on a couple PCs. While building and running a simple workflow that only retrieves field values I get the below error; older workflows run normally. Attempting to open the published workflow through the server either gives the same error or it does nothing. This came up during a training call with our VAR, and the working assumption is that it's because the server is still on an older version (11.0.2102.264). Is this a known issue?

The input is not a valid Base-64 string as it contains a non-base 64 character, more than two padding characters, or an illegal character among the padding characters.


When I save both to WFX and compare the files, the only differences I see are the obvious IDs/keys, cipher key, and file paths. Removing Retrieve Field Values and having nothing or just an Assign Token Values action the workflow runs, along with pulling global values.


Thank you!


1 0


replied on July 18, 2023 Show version history

To me this wouldn't be considered an issue. As a best practice your server versions should always be on a higher version or the same version as the clients that connect to it.

0 0


replied on April 18

I am seeing this issue as well. Has any bug been filed for this? The versions of the products match so its not related to version mismatch.

1 0
replied on July 18, 2023

This one specifically is a side-effect of the changes needed to strengthen the encryption algorithm for connection profiles.

The Server always needs to be a version equal or higher than the Designer. In general for Workflow, you can use a newer Designer to open and view workflows, but publishing changes is not guaranteed to work. The Designer would have popped up a message like this when you connected to an older server:

0 0
replied on March 20

Hey Miruna,

I have a customer who is receiving the same error, but the WF Designer version is higher on the server then on their workstation:




0 0
replied on March 25

Please upgrade the workstation to match the server version.

0 0
replied on March 26 Show version history

I just ran into this same issue on a customer server, however both the Workflow server and designer were the same build (11.0.2306.898).

The error occurred in one specific workflow that had a SQL query activity was reaching out to a database table.  It didn't matter what settings I changed, whenever I even tested the lookup, I would get this Base-64 string error.

Ultimately, I created a new data source.  The configuration, credentials, everything matched 100% with the broken data source. 

I could side by side test the broken one and then the new one successfully.

0 0
replied on March 27

What type of data source? Windows ODBC, direct connection or custom SQL connection string?

0 0
replied on April 18

Sorry Miruna, I didn't see this reply.  it was a direct connection to a MSSQL DB

0 0
replied on June 12

We are having the same problem with several activity types in workflow. We see it with Retrieve Field Values, Move Entry, Rename Entry, Create Entry, and Custom Scripts. I haven't seen it with a Custom Query though. It doesn't always happen, but we see it many times a day.

Of course, the first thing we did was look at all text related to the entries and we never found illegal or multiple padding characters. We've been working with our vendor on this and haven't been able to find a solution for over three months.  Both the workflow server and workflow designer are on version 11.0.2306.898.

If anyone has found a resolution, could you point us in the right direction?

Thank you!


0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.