You are viewing limited content. For full access, please sign in.

Question

Question

PDF Table Fill

asked on September 22

I have a form that has a table with a range of rows from 1-5.  Part of the workflow on submit fills out a PDF form.

I submit the form with two rows:

My fill PDF activity is set to fill out all 5 of the rows on the PDF but the tokens are formatted to do the correct iteration and NULL if there isnt any information.

When the PDF is filled and generated I get the correct two rows that I put on the form but then the rest is filled with same as the last row.  It's always the last row I have tried more than two:

How can I get the PDF to fill out with only the rows submitted?

 

Thanks,

Chris

0 0

Answer

SELECTED ANSWER
replied on September 22

This is because indexing past the last value in a multi-value token will get you the last value. So rows 3-5 will get the same value as row 2.

Any reason you're setting each row instead of doing a table merge?

0 0
replied on September 22 Show version history

Final Edit:

Alright, since the table merge does not support multiple tokens in the same column I tried updating a token.  Final solution is to create a multivalue token, do a For Each Row and piece together the info you need.  Then use that multivalue token in the table merge.  Got it working now.

 

Edit:

I figured out the Table part.  You just start typing it seems.  Looks like you need to have the row variables the same with _row_1 and so forth.  Looks like that worked, thank you for the pointer.

Also, it looks like you cannot use multiple tokens

On the form we have a To and From date fields like in the picture above.  However, this is just one column on the PDF form.

In the table merge, if I simply say From - To (a From token, a space dash space, then the To token) I get the following:

I created a new token and assigned it multivalues.

The token shows only one:

Even though the workflow shows both multi:

The ending PDF only did the first row for the dates.

Any thoughts on how I can get two variables into a single field on the table merge?

 

 

 

0 0
replied on September 26

That is correct. Putting any multi-value token combination into a single-line field will treat them as single-line tokens and use the first value in each. This is by design as Workflow won't guess as to how you want the tokens combined. You need to build the multi-value token ahead of time and use that by itself in the table merge.

0 0

Replies

You are not allowed to reply in this post.
You are not allowed to follow up in this post.

Sign in to reply to this post.