You are viewing limited content. For full access, please sign in.

Question

Question

New Form Designer - Field Rule to show a field only works on first record of collection

asked on May 11 Show version history

I'm using the new form designer and noticed a possible bug.  I have a field rule that shows a single line text box when a value is selected in a radio button group; the rule works fine on the first record in the collection, but when I add a new record to the collection ,the field is shown in the new record.  With two records in the collection, the first record shows the field correctly and the second record shows all fields as if the field rule is no longer being evaluated.

Please advise.  Thank you.

 

0 0

Answer

SELECTED ANSWER
replied on May 12

Sounds like the same issue from this question: https://answers.laserfiche.com/questions/198027/Unusual-Behavior-Collection-with-Field-Rules#198092

If so, it sounds like a known issue that is planned for fix in next release.

0 0
replied on May 12

Matt,

It is the same issue; thanks for the link to the other post.

1 0
replied on May 12

You're welcome.

0 0

Replies

replied on May 12

What version of forms are you using? 

I have just tested this out and works fine on version 11.0.2201. See image below.

Where it will display the single line if Choice 1 is selected. When adding a new row it keeps the field rule as expected.

1 0
replied on May 12

Hi Joe,

I am on version 11.0.2201.20436.  The radio button that I'm using is outside of the collection, so perhaps that is the issue. Having looked at the post that Matt linked, it appears to be the same scenario.

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.