You are viewing limited content. For full access, please sign in.

Question

Question

Forms: WF Activity not showing WF's from Dropdown

asked on September 14

Hello,

Customer is trying to utilize a WF Activity in their Form.

They are able to load the WF Server in the activity, but none of the WF's are populating and we are unable to add one manually.

We confirmed that the WF Server in the Forms Config is correct and validated, as well as the Forms URL is set in the WF Admin Console in Web Services section and verified.

Can't figure out why the WF Server populates but none of the WF's.

Appreciate the feedback,

Jeff Curtis

0 0

Answer

SELECTED ANSWER
replied on September 14

I have had a similar issue and it was due to the Security Options being set in the Workflow Administration Console.

If you View Workflow Options of the Workflow Definitions and you see the box is checked for "Only allow specified users to access the workflow" then forms won't see the workflow.

 

 

0 0
replied on September 14 Show version history

Rather than giving access to everyone, a more secure option would be to give the service account associated with Forms more permissions in the Security Settings of the workflow administration console.

We run our Forms instance with an AD service account, then set that account as an administrator Workflow Admin Console so it has access to all published workflows.

2 0
replied on September 14

Since Workflow Security is not well documented - I attempted to get Laserfiche to document whether your solution was a best practice for initiating Workflow Security.  Our VAR put in a support request for this for me, but Laserfiche support couldn't find anyone at Laserfiche that knew anything more about the feature than the minimal documentation that is provided. So we ended up turning it off in our production environment as access to workflows is extremely limited.

0 0
replied on September 14

Thanks Craig

0 0

Replies

replied on September 14

Thanks Jason

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.