You are viewing limited content. For full access, please sign in.

Question

Question

search repository - "no entry specified"

asked on April 30 Show version history

I'm trying to set up a workflow that will rename items that are already in the repository base on their metadata, however I'm having issues with the workflow finding a record at all. I usually get the "no entry specified" error message.

I've configured the search correctly, and am using the "for each entry" and then "rename entry" items. Am I missing something so that it will act on every entry found in the search? 

0 0

Replies

replied on April 30

In the properties of Rename Entry, look at the Entry panel. Do you have it set to rename the starting entry or the current entry from your For Each Entry?

Did you search find anything? You should be able to see the results count in the Messages tab in the instance details.

0 0
replied on April 30

Sorry, I miss-worded that. I do find items when testing the search repository, it was specifying the entry that wasn't working. It was able to find records, but wouldn't change any of them? (i want it to update all records found). 

 

0 0
replied on April 30

Can you confirm that the "For Each Entry" activity is configured to iterate over the output entries of your "Search Repository" activity? Also make sure that the "Rename Entry" activity is configured to rename the current entry from the "For Each Entry" iteration.

0 0
replied on April 30

I had the For Each Entry set up correctly, but I just adjusted the Rename Entry to look for the For Each Entry. I'm not longer having that error, but when I run the workflow it renames everything based on one document, rather than what is specific to each individual documents metadata... 

 

0 0
replied on May 4

What tokens are you using in the Rename Entry activity?

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.