You are viewing limited content. For full access, please sign in.

Question

Question

LF Cloud Queries Using SQL Unique Identifiers

asked on March 24 Show version history

Have a query I'm trying to run against an Incode (Tyler Financials) database to get Vendor information from the AccountsPayable.APVendor table.  The ID field for the vendors table is a SQL Unique Identifier field, which I need to use as an Input Parameter from workflow.

However when I test the query in the Cloud Query Builder using an ID like this:

37d693c0-1237-4015-8976-abf900fbd1b5

I get back "Invalid cast from 'System.String' to 'System.Guid'."

Queries against numeric and text fields work fine on that same table.

Is there a way to pass these Unique IDs as input parameters via Cloud?  I've tried putting the input value in single quotes which works in a regular SQL query, but I get the same error.

In addition, I notice in the documentation for building Queries in Cloud that there shows a way to set what type of parameter the input value is, but I'm not seeing that in the Query Builder.  Is this functionality no longer available?
Documentation shows:

Query Builder shows:

Thanks!

5 0

Replies

replied on March 25 Show version history

I'm not seeing the drop-down list to select the type of parameter either. I assume that this is a bug.

I also assume that without being able to set this value as a GUID/uniqueidentifier that the Run Rule function in Workflow will only ever accept tokens with a string value - which will cause the same error that you're seeing in the test function.

This also seems to affect other non-string parameter types such as DateTime.

I'd contact Laserfiche about this, as from my testing there seems to be no way around it.

0 0
replied on March 25

Thanks Stephen,

I had a chat and remote session with LF Support this morning regarding this.  They are currently researching it to escalate as a bug.

I only tested it with 2 types of fields, numeric and the GUID, but as you mentioned, I can see Date/Time and other types having issues.

Hopefully I'll know something soon.

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.