You are viewing limited content. For full access, please sign in.

Question

Question

Forms server replied: Forbidden on Archive to Repository

asked on February 22

We are getting the following error on some instances when trying to archive to the repository

Error: PdfNetworkError

The PDF generator was unable to contact the Laserfiche Forms server.

with network status code 202 and http status code 403 - Error downloading

server replied: Forbidden

However, this is forms just trying to talk to itself. It is not a bad security certificate either (which really shouldn't matter since certs are used to encrypted NETWORK traffic) This is literally just the software telling itself that it is forbidden to talk to itself.

I can't see anything in the configuration that would cause this.

0 0

Replies

replied on February 22

What version of Forms are you using? Can you provide the full error log from event log?

0 0
replied on February 23

Version: 10.4.2.381

I removed some of the domain info but here is the full error

The PDF generator was unable to contact the Laserfiche Forms server. Please ensure your SSL settings are correct. [LFF4112-PdfNetworkError]

Details:
URL: 
Error: PdfNetworkError
Date: 2/22/2021 1:34:00 PM (Pacific Standard Time)
HTTP Status Code: 404
Business Process ID: 60
Instance ID: 39431
Business Process Name: Customer Satisfaction Survey

Other:
aux: Loading pages (1/6)
[>                                                           ] 0%
[======>                                                     ] 10%
[========>                                                   ] 14%
[==========>                                                 ] 17%
[==============>                                             ] 24%
[================>                                           ] 28%
[===================>                                        ] 33%
[=====================>                                      ] 35%
[=======================>                                    ] 39%
[=========================>                                  ] 42%
[===============================>                            ] 52%
[======================================>                     ] 64%
[==========================================>                 ] 71%
[===========================================>                ] 73%
[=============================================>              ] 75%
[================================================>           ] 80%
[==================================================>         ] 84%
[====================================================>       ] 87%
[=====================================================>      ] 89%
Error: Failed to load https://.com/Forms/form/print/39431/85/60/49750/, with network status code 202 and http status code 403 - Error downloading https://.com/Forms/form/print/39431/85/60/49750/ - server replied: Forbidden
[============================================================] 100%
Counting pages (2/6)                                               
[============================================================] Object 1 of 1
Resolving links (4/6)                                                       
[============================================================] Object 1 of 1
Loading headers and footers (5/6)                                           
Printing pages (6/6)
[>                                                           ] Preparing
[============================================================] Page 1 of 1
Done                                                                      
Exit with code 1 due to network error: ContentOperationNotPermittedError


Stack Trace:
Caught exception: Laserfiche.Forms.CommonUtils.Exceptions.LFFormsException
Message: The PDF generator was unable to contact the Laserfiche Forms server. Please ensure your SSL settings are correct. [LFF4112-PdfNetworkError]
   at Laserfiche.Forms.CommonUtils.HtmlToPdfConverter.GeneratePrint(String& pdfFileLoc, String& tifFileLoc, SaveMode saveMode)
   at FormsModel.RoutingModels.Services.SaveFormToLaserficheStrategy.SaveMainFormToLaserfiche(Session session, XmlDocument datasetXml, STLConfigurationObj conf, SaveToLaserficheParameters saveToLaserficheParameters)

 

0 0
replied on February 24

Please view the form submissions from the instances that are suspended and check whether there are signature fields on those form with no proper data as following one:

If that is the case, it is the data that caused the error. 

You can run following query to check how many signature field value have such issue

select * from [dbo].[cf_bp_data] where attribute_id in (select attribute_id from [dbo].[cf_bp_dataset] where attribute_type='signature' ) and [value] not like 'data:image/png%' and [value] != ''

One known reason for generating such data is before Forms 10.4.0, the hidden signature field may auto filled with string by browser autofill functionality, this has been fixed in Forms 10.4.0. But we also got support cases with Forms 10.4.0 or above that there are signature with such data. We enhanced this since Forms 10.4.4 by adding data validation to the signature field in the front-end and backend to require the value of signature field to start with "data:image/png;base64".

The workaround to fix such data in order save to repository successfully is to run following query with the Forms database to update the value to be empty:

update  [dbo].[cf_bp_data] set [value]='' where attribute_id in (select attribute_id from [dbo].[cf_bp_dataset] where attribute_type='signature' ) and [value] not like 'data:image/png%' and [value] != ''

 

 

0 0
replied on February 24

This is really good information since I run into this signature issue all the time.

However in this case, they are not using a signature on the form.

0 0
replied on February 24

Found that changing their theme back to the default removed the forbidden message and successfully archived the form. So the Theme was what was forbidden. I submitted a copy of the form in a support ticket to find out what was wrong with the theme.

1 0
You are not allowed to follow up in this post.

Sign in to reply to this post.