You are viewing limited content. For full access, please sign in.

Question

Question

The PDF generator was unable to contact the Laserfiche Forms server while saving LF form to repository

asked on November 19

A simple business process with save to repository task is being suspended. Event viewer error log says "The PDF generator was unable to contact the Laserfiche Forms server. Please ensure your SSL settings are correct. ". Save to repository task works if I disable use ssl settings on Laserfiche forms configuration. I have a self signed certificate on the server.

I have tried various options but still not successful in rectifying the issue. Request for any input / ideas to try and rectify the above.

LF/Forms version 10.4

Thank you.

0 0

Replies

replied on November 20

Hi Bipin,

Which specific version of Forms are you using? Forms uses new PDF generation tool starting from 10.4.3. So the troubleshooting may be different between version before and after.

Also, could you provide the full error message in event log, which contains the stack trace that may give some hints.

 

Alternatively, there is an option to allow invalid certificate for PDF generation in Forms 10.4.5, you can try enable it if you are on this version 

  • Laserfiche Forms 10.4.5 allows PDF generation over SSL without a valid certificate. (248879)
1 0
replied one day ago

Hi Ziyan,

Thank you for your response.

I am planning to have forms upgraded to the latest version. I have 2 forms installation (one internal/ other on the DMZ). While upgrading, will the configuration on the xml files needs to be modified? (I had followed the whitepaper "Hosting Laserfiche Forms 10 In A Perimeter Network" to get it completed)

Thank you.

 

0 0
replied 19 hours ago Show version history

The upgrade should keep modified configuration unless Forms is uninstalled and then installed.

It is recommended to double check configuration following the whitepaper after upgrade, as there may be some extra configuration with newer version.

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.