You are viewing limited content. For full access, please sign in.

Question

Question

Comma Not Coming Over From Forms

asked on October 16

I have a (currency) field in forms that shows the comma if the currency value is large enough. When the form comes into the repository, the matching field (text) on the metadata template does not show the comma. Any ideas why? 

0 0

Answer

SELECTED ANSWER
replied on October 16

Using a comma (thousands separator) on the form field is a property of the field itself, but doesn't affect the data. If someone puts 1500 in the form field, the field knows to add the , to show 1,500, but the data is still 1500. Since you are sending this to a metadata text field, it gets the 1500 and just displays that. 

One option is to keep the metadata field as a text field, and build a regular expression mask that would insert a comma every after three characters. Or you could switch the metadata field to be a number field that has an option to show thousands separator. 

0 0
replied on October 16 Show version history

Changing the metadata field to a number and using the thousands separator now shows the comma on the template fields. Thank you!

 

I have a part two to this. I have a workflow that is taking those values to create a word document (via merge fields). The commas are not showing up there as well. 

0 0
replied on October 16

Since the formatting is only for display purposes, you have to change it where the data is displayed (so LF metadata or Word).

See https://support.microsoft.com/en-us/help/304387/date-phone-number-and-currency-fields-are-merged-incorrectly-when-you  for more on how to format merge fields in Word.

0 0
replied on October 19

Everything Worked like a charm. Thank you so much!!!!

0 0

Replies

You are not allowed to reply in this post.
You are not allowed to follow up in this post.

Sign in to reply to this post.