You are viewing limited content. For full access, please sign in.

Question

Question

Starting a Forms Business Process in Workflow without null references

asked on October 15

I keep getting reference errors in workflow with this activity, thought I determined it was a reference to a token that doesn't exist. But in this case every single reference is not NULL, I have verified it and can't explain why its still not compiling.

I refreshed to verify that no fields are missing from the form. I checked to verify that every token syntax is correct

I checked every token to ensure that they exist, since last time the problem was due to a token that didn't exist.

Nothing else that I can think of could be left null in this activity.

The problem started when I copied an Invoke Workflow from another workflow that invokes this workflow. I copied it to a NEW workflow and left it as it was, since it was already configured with out issue.

I was only able to resolve the null reference error by replacing the invoke workflow with a new non-copied one.

The invoke workflow only starts the workflow and passes parameters to the workflow which contains the activity with the null reference, can't see how it could possibly cause a null value, if anything it would pass a blank value.

 

0 0

Replies

replied on October 15

Hi Chad, can you please open a support case for this issue? 

0 0
replied on October 15

If I can come up with a simple way to reproduce it in a dev environment. I don't think there is any way I can send them this failed workflow in history so they can review where the missing reference was.

0 0
replied on October 15

We can get pretty close. That's why Tech Support asks for the contents of the Logs folder for Workflow cases. With the date and time from your screenshot and the logs, we can find this exact instance's detailed error.

You can look for the error yourself in the WF Admin Console under Monitoring\Error Logs\Current\activity errors.log. The stack trace for this specific instance will give us better insight into what was going on at the time.

1 0
replied on October 16

What I thought fixed it, copying the invoke, did not fix it. It just works when I test for some reason. Actually finding that even workflows started from before the change of which external workflow invokes this are failing now. Opened a support case. Here are the details from the log.

<ExceptionType>System.NullReferenceException, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089</ExceptionType>
<Message>Object reference not set to an instance of an object.</Message>
<Source>Laserfiche.Workflow.Activities.83.External</Source>
<HelpLink />
<Property name="ActivityName">CreateTaskinFormsforWOTC2</Property>
<Property name="ActivityType">Laserfiche.Workflow.Activities.Forms.StartFormFieldValueActivity</Property>
<Property name="InstanceId">d85fdd3a-1f08-435c-8f1d-548f19935b6f</Property>
<Property name="TargetSite">Laserfiche.Workflow.Activities.Forms.Runtime.StartFormsProcessTaskOptions CreateTaskOptions(System.Workflow.ComponentModel.ActivityExecutionContext, Laserfiche.Workflow.Activities.ITokenService)</Property>
<Property name="HResult">-2147467261</Property>
<StackTrace> at Laserfiche.Workflow.Activities.Forms.StartFormFieldValueActivity.CreateTaskOptions(ActivityExecutionContext executionContext, ITokenService tokenService)
at Laserfiche.Workflow.Activities.Forms.StartFormFieldValueActivity.ExecuteTask(ActivityExecutionContext executionContext)
at System.Workflow.ComponentModel.ActivityExecutorOperation.Run(IWorkflowCoreRuntime workflowCoreRuntime)
at System.Workflow.Runtime.Scheduler.Run()</StackTrace>

 

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.