You are viewing limited content. For full access, please sign in.

Discussion

Discussion

Directory Server Settings - License Management?

posted on September 20

I am getting a warning, doesn't seem to cause any problems, but in the Web Client configuration it says that the directory server address does not match what is configured in the License.

Forms does not complain about this, everything seems to work. But I want to fix it.

The problem is, in my DS settings on 10.4.3 I only have General, Email Server, Email Template, Password, Security, Identity Providers, and STS Sites.

I do not have a License option.

0 0
replied on September 20

Hi Chad,

I had this issue with a client too. 

What I found was that the server name in LFDS needed to be changed to the external server name and the lf.licx file re-created. For example, usually the license file is for the internal LFServername.domain

I changed it to match the external address, laserfiche.website.com

The endpoint configuration needs to done right too. I have done screenshots for my client but would have to redact them first, if you are interested?

 

Jonathan

0 0
replied on September 20 Show version history

To follow up on this, the "Directory Server address does not match what is configured in the License" error is referring to the contents of Web Client's lf.licx file. There's a block in there with the LFDS server's hostname. You'll get that warning if you provide a hostname for the LFDSSTS URL that's different from the value in the license.

The warning's intent is to alert people that they might have typo'd or otherwise put in an invalid STS endpoint address. Especially so for Web Client where if you have "Always Use SSO" enabled, it's quite easy to lock yourself out of the configuration interface if you put in the wrong address and can't get to the STS auth page.

If you're deliberately using a DNS alias, separate STS instance, etc., where entering a hostname other than the internal LFDS server's hostname is valid, you can and should ignore the warning. There's nothing to fix.

3 0
You are not allowed to follow up in this post.

Sign in to reply to this post.