You are viewing limited content. For full access, please sign in.

Discussion

Discussion

WebSTS - Use SSL default setting causing 'An error has occurred'

posted on March 25

I have encountered this issue for at least 3 different Clients where when logging into Laserfiche with the Web Client & Forms, we encounter the error:

An error has occurred

This issue seems to occur if in the WebSTS endpoint configuration, the Use SSL check box is enabled. Removing this checkbox resolves the issue. Also seems that in LFDS 10.4.3, this option is enabled by default.

Any ideas on why this would cause issues?

0 0
replied on March 26

I'd be curious if Laserfiche can share screenshots of the configurations of LFDS and WebSTS endpoints with Use SSL checked that is working.

In the scenarios that I have seen so far, both LFDS & WebSTS are on the same box/server.

0 0
replied on March 26

Just to add to what Karim is saying, I have never been able to get the Use SSL option to work without getting an error message.

0 0
replied on March 25

Hi Karim, in addition to Samuel's comment I'd like to stress that you should not disable SSL unless LFDS and STS are on the same machine (or unless this is a test environment with no sensitive user data). In previous versions of LFDS, message layer security was provided by WCF. We use raw HTTP now and transport layer security (HTTPS/SSL) is needed to maintain encryption.

2 0
replied on March 25

Hi Karim,

My guess is that HTTPS is not correctly configured on the LFDS side, so STS cannot reach LFDS over HTTPS.

Please see KB 1014134: HTTPS and WCF Configuration Information for Laserfiche Directory Server 10.4.3 HTTPS Configuration section steps 1 through 3.

Cheers,

1 0
You are not allowed to follow up in this post.

Sign in to reply to this post.