You are viewing limited content. For full access, please sign in.

Question

Question

Website requiring a client certificate

asked on March 25

I have a form (application) that has an external link on our website and, when applicants click on that link a window prompts asking:

"The website requires a client certificate"

and gives 3 options, shows certificate, cancel and, continue.

 

Once you click cancel, it will take you to the form but applicants don't know that. Is there any way that when clicking the link take you directly to the form and not prompting the window?

Thank you for your assistance in advance.

 

 

 

0 0

Replies

replied on March 25

Hi Veronica,

Whatever is happening here is occurring "outside" of Laserfiche. Laserfiche web applications do not, to my knowledge, even support client certificate authentication out of the box.

If I'm understanding the scenario correctly, you have a Laserfiche Forms Portal instance that is publicly accessible. You have a link to a starting form on your organization's website. When an external user (applicant) clicks on the link, a browser prompt appears with "The website requires a client certificate".

I did a bit of research and found a few possible causes. 

  1. The IIS site hosting the public Forms instance may be incorrectly configured to challenge for certificate authentication. See: Microsoft - "403.7 Forbidden: Client Certificate Required" error when you open an IIS webpage
  2. It may be an error specific to the Safari browser and Apple keychains. The vast majority of search results I found for the issue were Mac-related. See: Safari error: This website requires a client certificate and Safari incorrectly demands to select an SSL client certificate
  3. You may have a proxy in front of the Forms instance that is requesting certificate authentication.

 

Hope that helps. I would send this information to your IT team (if that's not you) and check if internal users on Windows computers using Chrome/Firefox/Edge get the same error when accessing the link.

Cheers,

Sam

1 0
replied on March 25

This is very helpful information, I'm forwarding this info to my IT team. And yes, internal users get the same error when accessing the link.

Thank you Sam!

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.