You are viewing limited content. For full access, please sign in.

Question

Question

Import users into repository

asked on February 10

I have the task of adding 500 new users to a repository and creating separate folders for them with individual secure access.

I have managed to import users into LFDS with assigned licenses from a CSV.

I have created a workflow that can read a Laserfiche group, find users and create individual secure folders.

The part that is missing is adding the LFDS users to a particular repository.  I can add them individually through Admin Console.  Is there a method for bulk importing users from LFDS into a repository?

I have tried importing an LFDS Group but the users do not appear to be available through workflow.

  

 

0 0

Replies

replied on February 14

I add users in bulk using the following XML file. Just add "Domain\username" for the name attribute (name="") and upload it via the web management app. It is still kind of labor intensive but much better than adding one-by-one. I spent some time trying to automate and merge my users into the file, but after a while i just resorted back to filling it manually. If anybody has a better solution, please share it . 

 

<?xml version="1.0" encoding="UTF-8"?>
<repository xmlns="http://laserfiche.com/namespaces/cr/" version="1.1" app="admin.10.2">
                <windowsaccountdefs xmlns="http://laserfiche.com/namespaces/cr/" version="1.1" app="admin.10.2">
                                
<windowsaccount id="1" name="" is_readonly="0" access="trust" >
                                                <featurerights scan="0" import="0" search="0" print="0" export="0" edittext="0" move="0" process="0" extended="0" delete="0" migrate="0" applywater="0" />
                                                <privileges trustees="0" volumes="0" entryaccess="0" modifyfields="0" createfields="0" stamps="0" tags="0" links="0" privileges="0" connections="0" config="0" purge="0" index="0" activitylog="0" bypassfilter="0" bypassbrowse="0" managefilter="0" externaltable="0" auditview="0" auditsettings="0" rm="0" managecert="0" entrycomment="0" delrevision="0" classification="0" />
                                                <audit inherit="1"/>
                                                                                                
                                </windowsaccount>
<windowsaccount id="1" name="" is_readonly="0" access="trust" >
                                                <featurerights scan="0" import="0" search="0" print="0" export="0" edittext="0" move="0" process="0" extended="0" delete="0" migrate="0" applywater="0" />
                                                <privileges trustees="0" volumes="0" entryaccess="0" modifyfields="0" createfields="0" stamps="0" tags="0" links="0" privileges="0" connections="0" config="0" purge="0" index="0" activitylog="0" bypassfilter="0" bypassbrowse="0" managefilter="0" externaltable="0" auditview="0" auditsettings="0" rm="0" managecert="0" entrycomment="0" delrevision="0" classification="0" />
                                                <audit inherit="1"/>
                                                
                                                
</windowsaccount>
</windowsaccountdefs>
</repository>

 

1 0
replied on February 16

Thanks Fernando.  I have managed to create a user import file in XML.  I used the following for importing LFDS users.  Given that most of the parameters are default settings, you can trim the XML down to just the following:

<?xml version="1.0" encoding="UTF-8"?>
<repository xmlns="http://laserfiche.com/namespaces/cr/" version="1.1" app="admin.10.2">
	<lfdsaccountdefs xmlns="http://laserfiche.com/namespaces/cr/" version="1.1" app="admin.10.2">
		<lfdsaccount name="jsprat" sid="S-1-9-12246189-2621016272-1219667209-459542400-718679700-17" >
		</lfdsaccount>
		<lfdsaccount name="jbrown" sid="S-1-9-12246189-2621016272-1219667209-459542400-718679700-14" >
		</lfdsaccount>

	</lfdsaccountdefs>
</repository>

 

 

0 0
replied on February 16
0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.