You are viewing limited content. For full access, please sign in.

Discussion

Discussion

Forms Report Filter, Stuck on Value is required when filtering by lookup data

posted on January 13

I think we have a situation where the helper systems in the UI are being so helpful they are blocking the ability to continue.

We want to filter the report by Case File Name, which is a lookup field. But when we select from the drop down, we can see that the lookup is not carrying over to the report UI. It is working on the form, just not the report.

"Loading data.." is the default value of the field until the lookup finishes, where it is replaced by the lookup values.

Well its ok that the Lookup hook is not passing through and it wasn't able to help us find our selection, because we know what we are looking for already.

However no matter what we enter into the field it thinks that no value is there and disables the set filter button. So there is no way to continue with our filter.

How can we filter by lookup data if both the lookup hook isn't passing through properly and the set filters button is being disabled.

0 0
replied on January 14

We've added a feature request to remove that restriction on custom report filters.

One thing you could do for instances going forward is add a hidden single line field with a calculation =DropdownField. Since that field is a single line, you could use the free input in the custom report filters. 

0 0
replied on January 14

Hi Jared

Calculations are performed on the browser for new submissions only right? I don't think this would allow me to filter in the current report.

0 0
replied on January 14

Right, unfortunately this would only work for instances going forward. 

0 0
replied on January 14

Ok, I will make a post to see if this can be done using Repository Search

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.