You are viewing limited content. For full access, please sign in.

Question

Question

How can I go to the next step in my process if all tasks are finished?

asked on January 10

Hi all!

 

I need to create a processus with 3 possibilities (way 1, way 2 or Way 1 and 2).

I don't really know how to do. I have some difficulty with the bridge.

 

For the first bridge, in my mind, this is correct.

 

But, for the next bridge, how can I say

 

if only way 1 (1 is finished) => next step

OR

if only way 2 (2 is finished) => next step

OR

if way 1 AND way 2 (1 and 2 are finished) => next step

 

Thank you in advance.

 

Regards

 

0 0

Answer

SELECTED ANSWER
replied on January 11

The issue is that the 'If all conditions is finished' inclusive gateway will always wait for all incoming paths to come in before proceeding to the next step. So in your case, you have 2 incoming paths, but not each path will be taken all the time. A way to get around this is instead of using an inclusive gateway at the beginning to do something like this:

In this case it will go to each path every time, but the Exclusive gateways determine if it will go to the user tasks. If not, it will skip over and meet back up at the 2nd Exclusive gateway for that path and then to the Parallel Gateway. This way you can ensure that each time every path will always come back to the merging parallel gateway.

1 0
replied on January 11 Show version history

Hi Blake,

That's actually not the case. Since version 10, when merging paths,

Exclusive - Allows all paths through individually

Parallel - Waits for all paths

Inclusive - Waits for all active paths

As a result, the structure he has will do what he wants, it is just a matter of setting the right conditions on the outflows for the first gateway.

I know there used to be some issues, but I tested to confirm the gateways function as described before posting my response.

https://www.laserfiche.com/support/webhelp/Laserfiche/10/en-US/administration/#../Subsystems/Forms/Content/Gateways.htm%3FTocPath%3DForms%7CCreating%2520a%2520Process%7C_____4

0 0
replied on January 11

Well I'll be. That is fantastic news.

0 0
replied on January 11

Indeed! Always nice to find out a workaround isn't needed anymore!

0 0

Replies

replied on January 10 Show version history

This should be the correct configuration.

Inclusive gateways should wait for active branches.

  • If it is only 1, it will not wait
  • If it is only 2, it will not wait
  • If it is 1 and 2, it will wait for both

 

The problem I see is your Conditions.

"Code_barre" can never equal both 1 and 2 because it is the same variable.

0 0
replied on January 11

Hi all,

 

Thank for your return.

@████████, my variable "Code_barre" can be = 1 AND 2 because it's a collection.

The user can add a new line and chose the both solution.

 

@████████, your solution should work ; i'm going to try it.

 

Thanks a lot.

0 0
replied on January 11 Show version history

Olivier,

Blake's solution is not necessary unless you're using Forms 9. In Forms 10, the structure you have is correct.

The collection is the problem. When you evaluate the value of a collection, it is the entire collection, not individual values.

If you have a "1" and a "2" in the collection, the value of "Code_barre" is actually "1, 2" because it is a group of values.

Currently, there is no way to check for specific values inside of a collection variable, so you'll need a different solution.

 

Instead, try creating two hidden fields on your form and use functions to check the collection for your target values.

For example,

  • Value_1  -==>    =(COUNTIF(Collection_1.Code_Barre,"=1") > 0)
  • Value_2  ==>     =(COUNTIF(Collection_1.Code_Barre,"=2") > 0)

 

Then, use those non-collection variables in your gateways instead. (Be sure to replace "Collection_1" with the actual variable of your collection.

The end result is this:

Value 1 is true because there's a 1 in at least one row.

Value 2 is false becouse there's no 2 anywhere.

 

If I add a 2 anywhere in the collection:

Both are now true.

 

1 0
replied on January 14

Hi Jason, thank you for your return.

This is great. I'm going to try your solution too.

Regards

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.