You are viewing limited content. For full access, please sign in.



Error: The user account name or password is incorrect.

asked on June 28, 2018

2 days ago our Workflow server in QA started giving a problem to find users against the configured trustee directory. So it only effects any activity that has to look up a user profile. Even when opening Designer and going to Tools \ Configure Trustee Directories, selecting the relevant directory and attempting to search a user results in the error below:

The Error details with diagnostic data is as follows:

An error occurred while searching for users. Error: The user account name or password is incorrect. [9010] [0339-WF1]
The user account name or password is incorrect. [9010]
---Stack Trace---

Server trace:
Laserfiche.RepositoryAccess.AccessDeniedException: The user account name or password is incorrect. [9010]
   at Laserfiche.RepositoryAccess.Session.SendLogInRequest(String idnRepName, HttpCredential credentials)
   at Laserfiche.RepositoryAccess.Session.LoginToServer(RepositoryRegistration repository, HttpCredential credentials)
   at Laserfiche.Connection.Lfso.RepositoryAccess91.LFConnectionRA.Login()
   at Laserfiche.Connection.ConnectionManager.CreateConnectionEx(ConnectionInfo connectionInfo)
   at Laserfiche.Connection.ConnectionManager.OpenConnectionInternal(ConnectionInfo connectionInformation)
   at Laserfiche.Connection.ConnectionManager.OpenConnection(ConnectionInfo connectionInformation)
   at Laserfiche.Connection.Lfso.LFConnection.OpenConnection(ConnectionInfo info, LfsoVersion version)
   at Laserfiche.Workflow.Runtime.DirectoryServices.LaserficheDirectoryUserProvider.SearchForUsers(WorkflowUserPropertyProxy proxyProperty, String searchString, SearchForUserOptions options)
   at Laserfiche.Workflow.Operations.DirectoryServices.SearchForWorkflowUsersOperation.Execute(WcfOperationContext context)
   at Laserfiche.Workflow.Runtime.Systems.SubsystemCommandHandler.ProcessExecuteCommand(ExecuteOperationCommand command)
   at Laserfiche.Workflow.Runtime.WcfSubsystem.ExecuteOperation(OperationCommand operation)

Client trace
   at Laserfiche.Workflow.Internal.WorkflowServerClient.ExecuteCommand(OperationCommand data)
   at Laserfiche.Workflow.WorkflowServerClientExtensions.ExecuteCommandInternal(IWorkflowServerApi api, ExecuteOperationCommand command)
   at Laserfiche.Workflow.Objects.DirectoryServices.TrusteeDirectory.<Search>d__0.MoveNext()
   at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection)
   at Laserfiche.Workflow.UI.WorkflowUserSearchDialog.ProcessResults(IEnumerable`1 results)
   at Laserfiche.Workflow.UI.WorkflowUserSearchDialog.RunSearch()



Based on similar posts that implied the connection profile being the problem I checked this and my current profile does validate successfully when you test it. Even though it worked, I tried changing the password for the user in the Connection profile, Creating a completely new user and password, all of which succeed when you validate the profile, but when searching for a user like above, the same error occurs. The same happens at run time when a workflow tries to get a user from a Find User activity, or the like. 

I also tried deleting and re-creating the Trustee Directory but this did not make any difference. 

Also tried to run the Workflow and Subscriber Configuration utilities again, setting those settings up from scratch. 

None of the above seems to make any difference. Any other activity connecting to the Repo like retrieving values, or assigning templates and values or routing is 100% working, so the problem is isolated to finding users, which seems to imply does not use the user configured in the connection profile. 

Any advise will be greatly appreciated. 



0 0


replied on June 28, 2018

an Update on the issue. 

I finally resorted to running a repair on the WF install and then once again deleting the Trustee Directory and Creating it again. This time it seems to have worked and the problem seems to be solved. 

Would still like to understand what possibly could have gone wrong.

0 0
replied on June 28, 2018

9010 indicates the user in the connection profile could not log into the Laserfiche repository. If you haven't changed the password for that user, then it's something on the Laserfiche Server side (possibly transient from your description).

0 0
replied on December 5, 2019

I had a similar issue to this recently, [9010 error].
In the end I updated the password for the workflow user and restored the connection profile to default.
Then after a restart of the Laserfiche server service it started working again.

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.