asked on June 13 Show version history

I have a script that collates data and wraps it in an HTML table. If I assign the HTML to a string and send the email from within the script using system.net.mail.mailmessage object, the email I receive renders the HTML correctly. However if I put the HTML into a token using SetTokenValue

SetTokenValue("HTMLBodyText", sbHTMLOutput.tostring)

use an email activity with the assigned token %(HTMLBodyText), the email received just comes through as plain text.

Anyone had the same experience or better still has a resolution ?

Thanks

Colin.

PS.  Just a couple of points for clarity.

Advance settings - "Send a plain text email" is unchecked.
Putting HTML directly into the body of the activity email does render the html in the received email correctly.

UPDATE

This is now resolved using the formatting for HTML. In the email editor, highlight the token, right click and select 'Token Editor'. Tick 'Apply formatting' and enter HTML. 

https://www.laserfiche.com/support/webhelp/Laserfiche/10/en-US/administration/#../Subsystems/LFWorkflow/Content/Resources/Activities/Email/E-mail.htm?Highlight=HTML
 

 

htmformat.PNG
htmformat.PNG (34.64 KB)
1 0