You are viewing limited content. For full access, please sign in.

Question

Question

LaserRepository configuration error - Your Windows account lacks sufficient rights to Sql Server

asked on October 12

Error:

Your Windows account lacks sufficient rights to Sql Server 'laserfiche\sqlexpress'. [LFF14-WindowsAccountUnabletoAuthenticateToSQL]

I am getting this error in Forms configuration when trying to save the forms database config and don't know how to fix it.

Forms v 10.2

SQL Server Express 2014

1) Forms routing service login changed from Local system to my admin account and service was restarted. Still get the error.

2)Changed login using SQL authentication and still get error.

3) I can login to SQL Express no problem.

 

Suggestions???

0 0

Answer

SELECTED ANSWER
replied on October 12

the Sa account was disabled. Don't know why. hmmmm.

0 0

Replies

replied on October 12 Show version history

Is it for a new Forms install, or are you connecting to an already existing Forms database?

It is possible to log into a database and do queries, but still not have enough rights to connect to the forms database with Forms Routing Service. Did you look at the database properties and view the effective rights? 

I'd recommend you create a database or domain account specifically for Forms instead of using your admin account. If you're just using that account to troubleshoot, I'd recommend you try the sa account. 

I've been hunting around for the minimum permissions needed by the accounts running the various Laserfiche services for a few weeks, and I cannot find them. It would be nice if Laserfiche included those in the release notes for the different products.

0 0
SELECTED ANSWER
replied on October 12

the Sa account was disabled. Don't know why. hmmmm.

0 0
replied on October 12 Show version history

That's a good thing. You don't want to use the sa account except for setup and troubleshooting. It implies that someone locked that server down, so there's a good chance your admin account doesn't have full rights to the SQL server.

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.