You are viewing limited content. For full access, please sign in.

Question

Question

Incorrect Date Format on Certain browsers Forms and Web Client

asked on July 19, 2017

I have an issue regarding the date format on certain browsers. Using Forms or Web Client the date is in the MM/dd/yyyy format. This only happens when using Firefox or Chrome. Internet Explorer is fine (dd/MM/yyyy).  I have Googled and searched on Answers Forums. Is there a regional or date setting somewhere that I have missed?

 

When I am on the Laserfiche server itself all browsers display in dd/MM/yyyy format. 

I changed the RoutingEngineServiceHost.exe config file on the LF server to match the dd/MM/yyyy format and set the other value to false (as per answers forum)

 

Any thoughts, suggestions or answers will be appreciated :o)

0 0

Answer

SELECTED ANSWER
replied on July 20, 2017

Hi Jonathan,

The date format on Forms website depends on your browser locale.

So if you changed browser language to en-au (English Australia) in Firefox/Chrome, the date format should be dd/MM/yyyy.

The setting in RoutingEngineServiceHost.exe config has nothing to do with date format on website; it affects date format used when save to repository.

1 0

Replies

replied on November 23, 2017

Hi Jonathan,

Did you get to the bottom of this as I am having the same issue with FF and Chrome? IE is fine. Changing the Region in either browser did not resolve the Issue.

 

0 0
replied on November 23, 2017

Hi Kyle,

There was a couple of things apart from the Region setting.

Making sure that the Date field was also formatted to dd/MM/yyyy and this JavaScript...

$(function() {
  $(document).ready(function () {
    $('.15Date input').on('change', function() {
      var dateCalendarPart = moment($('.15Date input').val(),'DD/MM/YYYY');
      var year = dateCalendarPart.year();
      var month = dateCalendarPart.month();
      $('.15Date input').val(moment().year(year).month(month).date(15).format('DD/MM/YYYY'));
    });
  });
});

This JS also sets the date to the 15th of that month though. That was the requirement for this particular form.

 

Jonathan

0 0
replied on May 22, 2019

Faced similar issue with a customer.

To rectify the issue, need to change the browser language to the appropriate region and make sure to relaunch the browser. For chrome, please access Settings --> advanced  --> Language (select language and opt to move it to the top) and then relaunch.

 

Thank you.

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.