You are viewing limited content. For full access, please sign in.

Question

Question

There was an error while applying your changes. at WebAuditConfig.ConfigurationService.AddSearchableData(RangeType type, Object[] parameters) at WebAuditConfig.ConfigurationService.AddRepositoryWizardData(RepositoryWizardInfo repositoryWizardInfo)

asked on May 15, 2014

 Receiving the above error when trying to Configure Repository for Audit Trail.  Got the above error from the Event Viewer...any ideas?  Running everything locally on PC (trying to test something).

0 0

Answer

SELECTED ANSWER
replied on June 12, 2014

I have same issue we faced today and i have solve it, we have 2 Node SQL Cluster and when we need to configure Audit trail the error massage appear same your error message this issue because we don't have permission to create DB on SQL Server so you need to give a permission for the user you have try to configure Audit trail that's it.

0 0

Replies

replied on May 15, 2014

Please check application event log and see if you have a login failure for the time when you attempted the configuration.  Normally that would be the cause.  The application log should give you the account that failed and what SQL db it is trying to login to when it fails..  In which case, you should give that account full rights to the SQL db.

 

If that is not the case, or you cannot find the entry, please open a Support Case.

0 0
replied on May 15, 2014

I was trying to create a New Database from the Audit Trail Configurator, which is why I was getting the error.  If I simply chose the Repository DB that was already listed, then it worked.  This is for testing purposes only, so I will move forward unless there's any risk of using the Repository DB as the DB for the Audit Reports?

0 0
replied on May 15, 2014

If it's just for testing, that's ok.

1 0
replied on May 15, 2014 Show version history

This sounds like a bug that was fixed in the 9.1 release of Audit Trail.  The log you provide to support can confirm it, and the solution will be to upgrade.

0 0
replied on May 15, 2014

Already on the latest version of 9.1.1.486

0 0
replied on May 16, 2014

Did you check the application log for any login failures at the time of the message? If so, what does the log say?

0 0
replied on May 16, 2014

Raymond,

The above message that I posted as the question, was actually the message from the Application Log.

0 0
replied on May 21, 2014

Are you getting a login failure in the application log? If so, for what account?

0 0
replied on October 20, 2016

i have same issue, in audittrail 10.1

Ocurrió un error mientras se aplicaban sus cambios.    at WebAuditConfig.ConfigurationService.AddSearchableData
(RangeType type, Object[] parameters)
   at WebAuditConfig.ConfigurationService.AddRepositoryWizardData(RepositoryWizardInfo repositoryWizardInfo)

the database user has all permissions, well I can not deploy the database list.

please help me,

 

 

audit_trailerror.PNG
0 0
replied on January 13

I too am running into this error with Avante 10.1.  Is there a resolution?

I've tried uninstalling and reinstalling Laserfiche Server.  I've tried manually creating the DB first, then connecting to an existing one as well as having Audit Trail create the DB.  I get the same error either way. I am certain that the account I'm using to access SQL has sysadmin and db_owner permissions.

0 0
replied on June 15 Show version history

I am running Avante 10.2.1 and getting exactly the same error, and yes, I checked DB login, permissions, etc.,  manually creating the DB first, then connecting to an existing one as well as having Audit Trail create the DB.  Error reported in Event Viewer is always at the Date Range point, (Ocurrio un error mientras se aplicaban sus cambios. en WebAuditConfig.WS.AddSearchableData(RangeType type, Object[] parameters) en WebAuditConfig.WS.AddRepositoryWizardData(RepositoryWizardInfo repositoryWizardInfo)  I get the same error either way and yes, I am certain that the account I'm using to access SQL has sysadmin and db_owner permissions.

Any resolution for this??? seems like a persistent error

0 0
replied on June 15

I have resolved this (for my purposes; I have a demo and testing installation that has 3 repositories configured, using SQL Express as the DBMS); what I did was change the login account in the Laserfiche Audit Trail Reporting Service from local system account (the default) to a local server administrator account; when running the repository wizard in Audit Trail config, and having SQL Express s the DBMS, apparently it takes by default as the DB owner, the user that is logged in at the moment; and there is no dialog or other method to change that. So, this means that, at the end, there´s a mismatch of users and accounts between the LF Audit trail service account and the Audit Trail DB owner, thus negating the permission to whenever you try to save settings in Audit Trail config.  

0 0
replied on June 15 Show version history

I guess there´s a better way to do this without changing the default account the Audit Trail service is running under: change the owner of the target AuditTrail database to the same account that Audit Trail service is running under. In the case of a default installation, that is local system account. So, change the owner of the audit DB from whatever it is to "NT AUTHORITY\SYSTEM"  before running the repository wizard in Audit Trail config. 

This is fairly easy to do in SSMS (Management Studio). Just go to Properties in the desired Audit DB and once there, go to the "Files" page and change owner from there. Ok it and run the Audit Trail repository wizard now. It should work like a charm. 

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.