You are viewing limited content. For full access, please sign in.

Question

Question

How do you directly approve a form from an email?

asked on December 27, 2013 Show version history

In the User Task, I've checked the box "Allow direct approval".  I'm able to approve it directly from the "My Tasks" page.  However, the email notification says just says:

"Click here to view the submission and approve/reject the submission in the browser


Click here to open this task in Forms."

 

Is there something else I'll need to add to the email notification in terms of Approve and Reject buttons?  Thanks for the help!

0 0

Replies

replied on December 29, 2013 Show version history

To make Email Approval work, there are following configurations needed:

  1. Prepare an email account for receiving emails:
  2. For this email account, create a folder to receiving the notification emails from Forms server when an email approval is triggered
  3. For this email account, create an email rule(http://office.microsoft.com/en-us/outlook-help/manage-email-messages-by-using-rules-HA010355682.aspx) to automatically route the notification emails sent from the email address configured in Email Notification Server(http://screencast.com/t/RL0ZInX6YJ) to the folder created in step 2.
  4. After the email account is prepared, go to Forms configuration site, then go to email settings tab and choose "email approval server" tab, configure the settings there, you can follow the instruction here: http://www.laserfiche.com/support/webhelp/laserficheforms/9.1/en-us/forms/#E-mail.htm( Set "Approval email account" to the account you prepared in step 1, set "Inbox folder" to the folder you created in step 2).

 

Some explanation for how the email approval works:

 When a task has "Allow direct approval" and "Email user when task is assigned" enabled, the task will be able to be approved via Email.

When send notification to the end users, it will send a reference email to the approval email account as well. Both the notification sent to end users and the reference email sent to the approval email account contain a header which is called "X-LFFORMS" which stored the unique id for the task.

The reference emails should be routed to a specific folder to distinguish it from the replied emails. You can route it based the send's email account as the reference emails will always be sent by that account. If you are using Gmail, you can follow http://webapps.stackexchange.com/questions/23839/can-you-create-rules-in-gmail to apply a specific label for those reference emails(The inbox folder you configure for email approval server will be the label name)

The "Inbox folder" configured under Email Approval Server is for monitoring the reference emails not the replied emails.  Replied emails will always be monitored from the Inbox directly.

 

When Forms process email approval, it will first read the replied email in the Inbox directly, then it will find the reference email from the folder configured from Forms Configuration site. If the unique id in the two emails match, then the task will be performed.

 

5 0
replied on May 22, 2015

I discovered what the problem was.  I had set the polling interval to one minute just for testing.  When I set it to 5 minutes it worked fine.  Too impatient. 

1 0
replied on February 4, 2014

Does there need to be a unique identifier in the email notification?  How does Forms know which response goes with which notification.  Can you put a detailed sample of the notification email out here?

0 0
replied on April 7, 2014

Hi Chad -

 

I'll bump this, because I have the same question. The Forms server "knows" when a particular user has saved a form for later completion, even when a user starts from the Public Portal.  So it's probably a safe assumption that it will know who approved what, via some kind of GUID or identifier.  Still it would be nice to get an official confirmation.

 

 

 

 

0 0
replied on May 4, 2015

So how would this work with a gmail account?  I created a gmail account.  Then created a "label" called ApprovalFolder.  Then I created a filter so that everything sent from that account would be moved into the ApprovalFolder.  But it's not working.  Also can the reply email have more than just the word Approve in it?  For instance if the user has a footer or disclaimer that gets sent automatically?

0 0
replied on May 4, 2015

Hello Janice,

 

A few things you can look into are

- Under FormsConfig, "test" both Approval and Notification Servesr

- Check the Event logs

- Ensure under "Polling Interval" you have some value there. Note that if it is at "0" email approval will be disabled

Something you can try actually, is just use a new simple google account without any extra filters or configurations, what not. Then configure it to that new gmail account, and leave the value under Email > Email Approval Server > "Inbox Folder" as "Inbox". Then respond to your direct approvals with "Approve" or "Deny". See if it works. If it does, then you can slowly customize it from there to filter out things and move it to certain folders, etc.

 

As for having more than just "Approve" or "Deny", it should still work. I've tried adding random gibberish after "Approve" and it still went through before. 

 

Hope this helps.

0 0
replied on May 5, 2015 Show version history

Hi Andrew.

- I did test both the approval and notification configuration.  Both come back as successful

- Nothing in the Windows Application event log

- I have the polling internal set to 1 minute

I did try using the gmail account with no filters but didn't reset the folder designation to Inbox.  I'll try that.  But if it would work just using the Inbox folder, why create a second folder?  Is that just to keep things neat and not necessarily a requirement?

Also, is the response Deny and not Reject? 

 

Thanks so much for your help.

0 0
replied on May 5, 2015

Hey Janice,

 

My apologies, the response is "Reject". But in any case, the email should prompt you with which valid choices are available. As for the folder designation, I suggested setting it to the default "Inbox" for now, just strictly as a test. You can change the path afterwards, after confirming that the very basic default configurations work. It just makes it easier to see where the configuration issue may be.

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.