You are viewing limited content. For full access, please sign in.

Question

Question

When Linking to Web Access PDFs, it Downloads Rather than Views in Browser

asked on June 14 Show version history

I don't know if this is expected behaviour, but it's concerning given the amount of downloads that will be required to manage this...

Essentially, when I'm in Web Access and emailing a link to a specific document, instead of opening in the browser, it downloads the document (which then opens in the browser anyway?)

Yet if I'm in the document viewer and email that URL, it will open in the browser viewer with no download.

Why does the former require a download? Isn't this counter-intuitive (E.g., creating more copies, taking up more space, requires an extra step by clicking on the link and then also the download to open the record, etc.)?

0 0

Replies

replied on June 14

Hi Robyn,

Default behavior for viewing PDFs can be set by users so that the document opens in the document viewer rather than automatically downloading.

You can find this setting in the Options page by clicking your username in the top right corner, then under Display:

0 0
replied on June 14

Hi Anita,

that is for viewing documents in the repository, not through email. I believe it's in the links. Notice this difference between the URL generated when sharing:

This URL downloads the document:

http://<Repository>/Laserfiche/ElectronicFile.aspx?db=<RepositoryName>&id=358248

This URL opens the document in the viewer:

http://<Repository>/laserfiche/DocView.aspx?db=<RepositoryName>&docid=358248

They are both the same excluding the bolded portion. I guess my question is why is the former used when emailing links rather than the latter?

0 0
replied on June 14

Hi Robyn,

Good point! That ElectronicFile URL is the one that would begin the download immediately. I've brought this up to the web client team and they'll work on improving how links behave for PDFs in the future so that it doesn't default to the download link.

1 0
replied on June 15

Thank you, Anita!

0 0
You are not allowed to follow up in this post.

Sign in to reply to this post.